CVE-2013-1418
SUSE Linux Enterprise Desktop 11 SP2,SUSE Linux Enterprise Desktop 11 SP3,SUSE Linux Enterprise Server 11 SP2,SUSE Linux Enterprise Server 11 SP2 for VMware,SUSE Linux Enterprise Server 11 SP3,SUSE Linux Enterprise Server 11 SP3 for VMware,SUSE Linux Enterprise Software Development Kit 11 SP2,SUSE Linux Enterprise Software Development Kit 11 SP3
CVE-2013-1418, security advisory, novell, suse linux, suse, security, cve

CVE-2013-1418

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-1418 at MITRE

Description

The setup_server_realm function in main.c in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) before 1.10.7, when multiple realms are configured, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted request.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.30
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 849240 [RESOLVED / FIXED], 866059 [RESOLVED / DUPLICATE], 879587

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Patchnames:
sledsp2-krb5
SUSE Linux Enterprise Desktop 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Patchnames:
sledsp3-krb5
SUSE Linux Enterprise Server 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.58.1
Patchnames:
slessp2-krb5
SUSE Linux Enterprise Server 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.62.1
Patchnames:
slessp3-krb5
SUSE Linux Enterprise Server for VMWare 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.58.1
Patchnames:
slessp2-krb5
SUSE Linux Enterprise Server for VMWare 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.62.1
Patchnames:
slessp3-krb5
SUSE Linux Enterprise Software Development Kit 11 SP2
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Patchnames:
sdksp2-krb5
SUSE Linux Enterprise Software Development Kit 11 SP3
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Patchnames:
sdksp3-krb5
SUSE Linux Enterprise Software Development Kit 11 SP3
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Software Development Kit 11 SP3
  • krb5-devel >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Software Development Kit 11 SP3
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Software Development Kit 11 SP3
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Desktop 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Desktop 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Server 11 SP3
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8534
SUSE Linux Enterprise Software Development Kit 11 SP2
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Software Development Kit 11 SP2
  • krb5-devel >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Software Development Kit 11 SP2
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Software Development Kit 11 SP2
  • krb5-devel >= 1.6.3-133.49.58.1
  • krb5-devel-32bit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Desktop 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Desktop 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-32bit >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
SUSE Linux Enterprise Server 11 SP2
  • krb5 >= 1.6.3-133.49.58.1
  • krb5-apps-clients >= 1.6.3-133.49.58.1
  • krb5-apps-servers >= 1.6.3-133.49.58.1
  • krb5-client >= 1.6.3-133.49.58.1
  • krb5-doc >= 1.6.3-133.49.58.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.58.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.58.1
  • krb5-server >= 1.6.3-133.49.58.1
  • krb5-x86 >= 1.6.3-133.49.58.1
Builds
SAT Patch Nr: 8533
openSUSE 12.3
  • krb5 >= 1.10.2-10.22.1
  • krb5-32bit >= 1.10.2-10.22.1
  • krb5-client >= 1.10.2-10.22.1
  • krb5-client-debuginfo >= 1.10.2-10.22.1
  • krb5-debuginfo >= 1.10.2-10.22.1
  • krb5-debuginfo-32bit >= 1.10.2-10.22.1
  • krb5-debugsource >= 1.10.2-10.22.1
  • krb5-devel >= 1.10.2-10.22.1
  • krb5-devel-32bit >= 1.10.2-10.22.1
  • krb5-doc >= 1.10.2-10.22.2
  • krb5-mini >= 1.10.2-10.22.1
  • krb5-mini-debuginfo >= 1.10.2-10.22.1
  • krb5-mini-debugsource >= 1.10.2-10.22.1
  • krb5-mini-devel >= 1.10.2-10.22.1
  • krb5-plugin-kdb-ldap >= 1.10.2-10.22.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.10.2-10.22.1
  • krb5-plugin-preauth-pkinit >= 1.10.2-10.22.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.10.2-10.22.1
  • krb5-server >= 1.10.2-10.22.1
  • krb5-server-debuginfo >= 1.10.2-10.22.1
Patchnames:
openSUSE-2013-880
openSUSE 13.1
  • krb5 >= 1.11.3-3.4.1
  • krb5-32bit >= 1.11.3-3.4.1
  • krb5-client >= 1.11.3-3.4.1
  • krb5-client-debuginfo >= 1.11.3-3.4.1
  • krb5-debuginfo >= 1.11.3-3.4.1
  • krb5-debuginfo-32bit >= 1.11.3-3.4.1
  • krb5-debugsource >= 1.11.3-3.4.1
  • krb5-devel >= 1.11.3-3.4.1
  • krb5-devel-32bit >= 1.11.3-3.4.1
  • krb5-doc >= 1.11.3-3.4.1
  • krb5-mini >= 1.11.3-3.4.1
  • krb5-mini-debuginfo >= 1.11.3-3.4.1
  • krb5-mini-debugsource >= 1.11.3-3.4.1
  • krb5-mini-devel >= 1.11.3-3.4.1
  • krb5-plugin-kdb-ldap >= 1.11.3-3.4.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.11.3-3.4.1
  • krb5-plugin-preauth-pkinit >= 1.11.3-3.4.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.11.3-3.4.1
  • krb5-server >= 1.11.3-3.4.1
  • krb5-server-debuginfo >= 1.11.3-3.4.1
Patchnames:
openSUSE-2013-941
openSUSE Evergreen 11.4
  • krb5 >= 1.8.3-67.1
  • krb5-32bit >= 1.8.3-67.1
  • krb5-client >= 1.8.3-67.1
  • krb5-client-debuginfo >= 1.8.3-67.1
  • krb5-debuginfo >= 1.8.3-67.1
  • krb5-debuginfo-32bit >= 1.8.3-67.1
  • krb5-debuginfo-x86 >= 1.8.3-67.1
  • krb5-debugsource >= 1.8.3-67.1
  • krb5-devel >= 1.8.3-67.1
  • krb5-devel-32bit >= 1.8.3-67.1
  • krb5-plugin-kdb-ldap >= 1.8.3-67.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.8.3-67.1
  • krb5-plugin-preauth-pkinit >= 1.8.3-67.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.8.3-67.1
  • krb5-server >= 1.8.3-67.1
  • krb5-server-debuginfo >= 1.8.3-67.1
  • krb5-x86 >= 1.8.3-67.1
Patchnames:
2013-164