Upstream information

CVE-2013-0249 at MITRE

Description

Stack-based buffer overflow in the Curl_sasl_create_digest_md5_message function in lib/curl_sasl.c in curl and libcurl 7.26.0 through 7.28.1, when negotiating SASL DIGEST-MD5 authentication, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long string in the realm parameter in a (1) POP3, (2) SMTP or (3) IMAP message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 802411 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • curl >= 7.37.0-2.5
  • libcurl4 >= 7.37.0-2.5
  • libcurl4-32bit >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Desktop 12 GA curl
SUSE Linux Enterprise Desktop 12 SP1
  • curl >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
  • libcurl4-32bit >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA curl
SUSE Linux Enterprise Desktop 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
  • libcurl4-32bit >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA curl
SUSE Linux Enterprise Desktop 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA curl
SUSE Linux Enterprise Module for Basesystem 15
  • curl >= 7.60.0-1.1
  • libcurl-devel >= 7.60.0-1.1
  • libcurl4 >= 7.60.0-1.1
  • libcurl4-32bit >= 7.60.0-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA curl
SUSE Linux Enterprise Server 12
  • curl >= 7.37.0-2.5
  • libcurl4 >= 7.37.0-2.5
  • libcurl4-32bit >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Server 12 GA curl
SUSE Linux Enterprise Server 12 SP1
  • curl >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
  • libcurl4-32bit >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA curl
SUSE Linux Enterprise Server 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
  • libcurl4-32bit >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA curl
SUSE Linux Enterprise Server 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA curl
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA curl
SUSE Linux Enterprise Software Development Kit 12
  • libcurl-devel >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libcurl-devel >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcurl-devel >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcurl-devel >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libcurl-devel
openSUSE Leap 15.0
  • curl >= 7.59.0-lp150.1.1
  • libcurl4 >= 7.59.0-lp150.1.1
  • libcurl4-32bit >= 7.59.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA curl
openSUSE Leap 42.1
  • curl >= 7.37.0-5.2
  • libcurl-devel >= 7.37.0-5.2
  • libcurl4 >= 7.37.0-5.2
Patchnames:
openSUSE Leap 42.1 GA curl
openSUSE Leap 42.2
  • curl >= 7.37.0-15.1
  • libcurl-devel >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
Patchnames:
openSUSE Leap 42.2 GA curl
openSUSE Leap 42.3
  • curl >= 7.37.0-18.5
  • libcurl-devel >= 7.37.0-18.5
  • libcurl4 >= 7.37.0-18.5
Patchnames:
openSUSE Leap 42.3 GA curl
openSUSE Tumbleweed
  • curl >= 7.51.0-1.1
  • libcurl-devel >= 7.51.0-1.1
  • libcurl-devel-32bit >= 7.51.0-1.1
  • libcurl4 >= 7.51.0-1.1
  • libcurl4-32bit >= 7.51.0-1.1
Patchnames:
openSUSE Tumbleweed GA curl