CVE-2013-0166
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries,SLE SDK 10 SP4 for IBM zSeries,SLE SDK 10 SP4 for IPF,SLE SDK 10 SP4 for X86-64,SLE SDK 10 SP4 for x86,SUSE CORE 9 for AMD64 and Intel EM64T,SUSE CORE 9 for IBM S/390 31bit,SUSE CORE 9 for IBM zSeries 64bit,SUSE CORE 9 for x86,SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T,SUSE Linux Enterprise Desktop 10 SP4 for x86,SUSE Linux Enterprise Desktop 11 SP2,SUSE Linux Enterprise Desktop 11 SP3,SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T,SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit,SUSE Linux Enterprise Server 10 SP3 LTSS for x86,SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T,SUSE Linux Enterprise Server 10 SP4 for IBM POWER,SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit,SUSE Linux Enterprise Server 10 SP4 for IPF,SUSE Linux Enterprise Server 10 SP4 for x86,SUSE Linux Enterprise Server 11 SP1 LTSS,SUSE Linux Enterprise Server 11 SP2,SUSE Linux Enterprise Server 11 SP2 for VMware,SUSE Linux Enterprise Software Development Kit 11 SP2,SUSE Linux Enterprise for SAP Applications 11 SP1,SUSE Linux Enterprise for SAP Applications 11 SP2
CVE-2013-0166, security advisory, novell, suse linux, suse, security, cve

CVE-2013-0166

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-0166 at MITRE

Description

OpenSSL before 0.9.8y, 1.0.0 before 1.0.0k, and 1.0.1 before 1.0.1d does not properly perform signature verification for OCSP responses, which allows remote OCSP servers to cause a denial of service (NULL pointer dereference and application crash) via an invalid key.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 802648 [RESOLVED / FIXED], 802746 [RESOLVED / FIXED], 813366 [NEEDINFO], 821818 [RESOLVED / FIXED], 833408 [RESOLVED / FIXED], 905106, 911906 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
Patchnames:
sledsp2-libopenssl-devel
SUSE Linux Enterprise Desktop 11 SP3
  • compat-openssl097g >= 0.9.7g-146.22.25.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.25.1
Patchnames:
sledsp3-compat-openssl097g
SUSE Linux Enterprise Server 11 SP1-LTSS
  • libopenssl-devel >= 0.9.8j-0.72.1
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Patchnames:
slessp1-libopenssl-devel
SUSE Linux Enterprise Server 11 SP2
  • libopenssl-devel >= 0.9.8j-0.66.1
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Patchnames:
slessp2-libopenssl-devel
SUSE Linux Enterprise Server for VMWare 11 SP2
  • libopenssl-devel >= 0.9.8j-0.66.1
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Patchnames:
slessp2-libopenssl-devel
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libopenssl-devel >= 0.9.8j-0.50.1
Patchnames:
sdksp2-libopenssl-devel
SUSE Linux Enterprise for SAP 11 SP1
  • compat-openssl097g >= 0.9.7g-146.22.25.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.25.1
Patchnames:
slesapp1-compat-openssl097g
SUSE Linux Enterprise for SAP Applications 11 SP1
  • compat-openssl097g >= 0.9.7g-146.20.24.1
  • compat-openssl097g-32bit >= 0.9.7g-146.20.24.1
Builds
SAT Patch Nr: 10032
SUSE Linux Enterprise for SAP Applications 11 SP2
  • compat-openssl097g >= 0.9.7g-146.22.29.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.29.1
Builds
SAT Patch Nr: 10507
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.76.1
  • openssl-32bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-32bit >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for x86
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for IPF
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
  • openssl-x86 >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • openssl >= 0.9.8a-18.76.1
  • openssl-64bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-64bit >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.76.1
  • openssl-32bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-32bit >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libopenssl-devel >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Desktop 11 SP3
  • compat-openssl097g >= 0.9.7g-146.20.24.1
Builds
SAT Patch Nr: 10033
SUSE Linux Enterprise Desktop 11 SP3
  • compat-openssl097g >= 0.9.7g-146.20.24.1
  • compat-openssl097g-32bit >= 0.9.7g-146.20.24.1
Builds
SAT Patch Nr: 10033
SUSE CORE 9 for IBM S/390 31bit
SUSE CORE 9 for x86
  • openssl >= 0.9.7d-15.48
  • openssl-devel >= 0.9.7d-15.48
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE CORE 9 for IBM zSeries 64bit
  • openssl >= 0.9.7d-15.48
  • openssl-32bit >= 9-201308121642
  • openssl-devel >= 0.9.7d-15.48
  • openssl-devel-32bit >= 9-201308121642
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE CORE 9 for AMD64 and Intel EM64T
  • openssl >= 0.9.7d-15.48
  • openssl-32bit >= 9-201308121627
  • openssl-devel >= 0.9.7d-15.48
  • openssl-devel-32bit >= 9-201308121627
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • openssl >= 0.9.8a-18.45.69.1
  • openssl-devel >= 0.9.8a-18.45.69.1
  • openssl-doc >= 0.9.8a-18.45.69.1
Builds
ZYPP Patch Nr: 8528
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.45.69.1
  • openssl-32bit >= 0.9.8a-18.45.69.1
  • openssl-devel >= 0.9.8a-18.45.69.1
  • openssl-devel-32bit >= 0.9.8a-18.45.69.1
  • openssl-doc >= 0.9.8a-18.45.69.1
Builds
ZYPP Patch Nr: 8528
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7564
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7564
openSUSE 13.2
  • libopenssl0_9_8 >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-9.3.1
Patchnames:
openSUSE-2016-294
openSUSE Evergreen 11.4
  • libopenssl-devel >= 1.0.0k-18.45.1
  • libopenssl1_0_0 >= 1.0.0k-18.45.1
  • libopenssl1_0_0-32bit >= 1.0.0k-18.45.1
  • libopenssl1_0_0-debuginfo >= 1.0.0k-18.45.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.0k-18.45.1
  • libopenssl1_0_0-debuginfo-x86 >= 1.0.0k-18.45.1
  • libopenssl1_0_0-x86 >= 1.0.0k-18.45.1
  • openssl >= 1.0.0k-18.45.1
  • openssl-debuginfo >= 1.0.0k-18.45.1
  • openssl-debugsource >= 1.0.0k-18.45.1
  • openssl-doc >= 1.0.0k-18.45.1
Patchnames:
2013-30
openSUSE Leap 42.1
  • libopenssl0_9_8 >= 0.9.8zh-14.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-14.1
Patchnames:
openSUSE-2016-294