CVE-2012-6076

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-6076 at MITRE

Description

Inkscape before 0.48.4 reads .eps files from /tmp instead of the current directory, which might cause Inkspace to process unintended files, allow local users to obtain sensitive information, and possibly have other unspecified impacts.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.38
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 796306 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • inkscape >= 0.46-62.38.1
  • inkscape-extensions-dia >= 0.46-62.38.1
  • inkscape-extensions-extra >= 0.46-62.38.1
  • inkscape-extensions-fig >= 0.46-62.38.1
  • inkscape-extensions-gimp >= 0.46-62.38.1
  • inkscape-lang >= 0.46-62.38.1
Patchnames:
sledsp2-inkscape
SUSE Linux Enterprise Software Development Kit 11 SP2
  • inkscape >= 0.46-62.38.1
  • inkscape-extensions-dia >= 0.46-62.38.1
  • inkscape-extensions-extra >= 0.46-62.38.1
  • inkscape-extensions-fig >= 0.46-62.38.1
  • inkscape-extensions-gimp >= 0.46-62.38.1
  • inkscape-lang >= 0.46-62.38.1
Patchnames:
sdksp2-inkscape
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP2
  • inkscape >= 0.46-62.38.1
  • inkscape-extensions-dia >= 0.46-62.38.1
  • inkscape-extensions-extra >= 0.46-62.38.1
  • inkscape-extensions-fig >= 0.46-62.38.1
  • inkscape-extensions-gimp >= 0.46-62.38.1
  • inkscape-lang >= 0.46-62.38.1
Builds
SAT Patch Nr: 7380
openSUSE Evergreen 11.4
  • inkscape >= 0.48.1-8.1
  • inkscape-debuginfo >= 0.48.1-8.1
  • inkscape-debugsource >= 0.48.1-8.1
  • inkscape-extensions-dia >= 0.48.1-8.1
  • inkscape-extensions-extra >= 0.48.1-8.1
  • inkscape-extensions-fig >= 0.48.1-8.1
  • inkscape-extensions-gimp >= 0.48.1-8.1
  • inkscape-extensions-skencil >= 0.48.1-8.1
  • inkscape-lang >= 0.48.1-8.1
Patchnames:
2013-26