Upstream information

CVE-2012-5612 at MITRE

Description

Heap-based buffer overflow in Oracle MySQL 5.5.19 and other versions through 5.5.28, and MariaDB 5.5.28a and possibly other versions, allows remote authenticated users to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code, as demonstrated using certain variations of the (1) USE, (2) SHOW TABLES, (3) DESCRIBE, (4) SHOW FIELDS FROM, (5) SHOW COLUMNS FROM, (6) SHOW INDEX FROM, (7) CREATE TABLE, (8) DROP TABLE, (9) ALTER TABLE, (10) DELETE FROM, (11) UPDATE, and (12) SET PASSWORD commands.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 792443 [RESOLVED / FIXED], 798753 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libmysqld-devel >= 10.2.22-3.14.1
  • libmysqld19 >= 10.2.22-3.14.1
  • mariadb >= 10.2.22-3.14.1
  • mariadb-client >= 10.2.22-3.14.1
  • mariadb-errormessages >= 10.2.22-3.14.1
  • mariadb-tools >= 10.2.22-3.14.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA libmysqld-devel-10.2.22-3.14.1
SUSE Linux Enterprise Desktop 11 SP2
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.1
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.1
  • mysql >= 5.0.96-0.6.1
  • mysql-client >= 5.0.96-0.6.1
Patchnames:
sdksp2-libmysqlclient-devel
sledsp2-libmysqlclient-devel
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libmysqld-devel >= 10.2.15-1.3
  • libmysqld19 >= 10.2.15-1.3
  • mariadb >= 10.2.15-1.3
  • mariadb-client >= 10.2.15-1.3
  • mariadb-errormessages >= 10.2.15-1.3
  • mariadb-tools >= 10.2.15-1.3
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libmysqld-devel-10.2.15-1.3
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.8.8.2
  • libmysqlclient15-x86 >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.1
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.1
  • mysql >= 5.0.96-0.6.1
  • mysql-Max >= 5.0.96-0.6.1
  • mysql-client >= 5.0.96-0.6.1
  • mysql-tools >= 5.0.96-0.6.1
Patchnames:
sdksp2-libmysqlclient-devel
slessp2-libmysqlclient-devel
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.1
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.1
Patchnames:
sdksp2-libmysqlclient-devel
openSUSE Leap 15.0
  • libmysqld19 >= 10.2.14-lp150.1.1
  • mariadb >= 10.2.14-lp150.1.1
  • mariadb-client >= 10.2.14-lp150.1.1
  • mariadb-errormessages >= 10.2.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libmysqld19-10.2.14-lp150.1.1
openSUSE Tumbleweed
  • libmysqlclient-devel >= 10.0.22-3.8
  • libmysqlclient18 >= 10.0.22-3.8
  • libmysqlclient18-32bit >= 10.0.22-3.8
  • libmysqlclient_r18 >= 10.0.22-3.8
  • libmysqlclient_r18-32bit >= 10.0.22-3.8
  • libmysqld-devel >= 10.0.22-3.8
  • libmysqld18 >= 10.0.22-3.8
  • mariadb >= 10.0.22-3.8
  • mariadb-bench >= 10.0.22-3.8
  • mariadb-client >= 10.0.22-3.8
  • mariadb-errormessages >= 10.0.22-3.8
  • mariadb-test >= 10.0.22-3.8
  • mariadb-tools >= 10.0.22-3.8
Patchnames:
openSUSE Tumbleweed GA libmysqlclient-devel-10.0.22-3.8


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 mysql Released
SUSE Linux Enterprise Desktop 11 SP2 mysql Released
SUSE Linux Enterprise Server 11 SP1 mysql Released
SUSE Linux Enterprise Server 11 SP1 LTSS mysql Released
SUSE Linux Enterprise Server 11 SP2 mysql Released
SUSE Linux Enterprise Server 11 SP2 LTSS mysql Released
SUSE Linux Enterprise Server 11 SP2 for VMware mysql Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 mysql Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 mysql Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 mysql Released
SUSE Linux Enterprise Software Development Kit 11 SP1 mysql Released
SUSE Linux Enterprise Software Development Kit 11 SP2 mysql Released
SUSE OpenStack Cloud 7 mariadb In progress


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 06:47:13 2013
CVE page last modified: Tue Nov 8 17:03:01 2022