Upstream information

CVE-2012-5133 at MITRE

Description

Use-after-free vulnerability in Google Chrome before 23.0.1271.91 allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to SVG filters.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 791234 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libjavascriptcoregtk-1_0-0 >= 2.2.7-3.63
  • libjavascriptcoregtk-1_0-0-32bit >= 2.2.7-3.63
  • libjavascriptcoregtk-3_0-0 >= 2.2.7-3.63
  • libwebkit2gtk-3_0-25 >= 2.2.7-3.63
  • libwebkitgtk-1_0-0 >= 2.2.7-3.63
  • libwebkitgtk-1_0-0-32bit >= 2.2.7-3.63
  • libwebkitgtk-3_0-0 >= 2.2.7-3.63
  • libwebkitgtk2-lang >= 2.2.7-3.63
  • libwebkitgtk3-lang >= 2.2.7-3.63
  • typelib-1_0-JavaScriptCore-3_0 >= 2.2.7-3.63
  • typelib-1_0-WebKit-3_0 >= 2.2.7-3.63
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Desktop 12 SP1
  • libjavascriptcoregtk-1_0-0 >= 2.4.8-16.2
  • libjavascriptcoregtk-1_0-0-32bit >= 2.4.8-16.2
  • libjavascriptcoregtk-3_0-0 >= 2.4.8-16.2
  • libwebkit2gtk-3_0-25 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0-32bit >= 2.4.8-16.2
  • libwebkitgtk-3_0-0 >= 2.4.8-16.2
  • libwebkitgtk2-lang >= 2.4.8-16.2
  • libwebkitgtk3-lang >= 2.4.8-16.2
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.8-16.2
  • typelib-1_0-WebKit-3_0 >= 2.4.8-16.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Desktop 12 SP2
  • libjavascriptcoregtk-1_0-0 >= 2.4.11-23.20
  • libjavascriptcoregtk-1_0-0-32bit >= 2.4.11-23.20
  • libjavascriptcoregtk-3_0-0 >= 2.4.11-23.20
  • libwebkit2gtk-3_0-25 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0 >= 2.4.11-23.20
  • libwebkitgtk-1_0-0-32bit >= 2.4.11-23.20
  • libwebkitgtk-3_0-0 >= 2.4.11-23.20
  • libwebkitgtk2-lang >= 2.4.11-23.20
  • libwebkitgtk3-lang >= 2.4.11-23.20
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.11-23.20
  • typelib-1_0-WebKit-3_0 >= 2.4.11-23.20
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Desktop 12 SP2 GA libwebkit2gtk-3_0-25
SUSE Linux Enterprise Server 12
  • libjavascriptcoregtk-3_0-0 >= 2.2.7-3.63
  • libwebkitgtk-3_0-0 >= 2.2.7-3.63
  • libwebkitgtk3-lang >= 2.2.7-3.63
Patchnames:
SUSE Linux Enterprise Server 12 GA libjavascriptcoregtk-3_0-0
SUSE Linux Enterprise Server 12 SP1
  • libjavascriptcoregtk-3_0-0 >= 2.4.8-16.2
  • libwebkitgtk-3_0-0 >= 2.4.8-16.2
  • libwebkitgtk3-lang >= 2.4.8-16.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libjavascriptcoregtk-3_0-0
SUSE Linux Enterprise Server 12 SP2
  • libjavascriptcoregtk-3_0-0 >= 2.4.11-23.20
  • libwebkitgtk-3_0-0 >= 2.4.11-23.20
  • libwebkitgtk3-lang >= 2.4.11-23.20
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libjavascriptcoregtk-3_0-0
SUSE Linux Enterprise Software Development Kit 12
  • libjavascriptcoregtk-1_0-0 >= 2.2.7-3.63
  • libwebkit2gtk-3_0-25 >= 2.2.7-3.63
  • libwebkitgtk-1_0-0 >= 2.2.7-3.63
  • libwebkitgtk-devel >= 2.2.7-3.63
  • libwebkitgtk3-devel >= 2.2.7-3.63
  • typelib-1_0-JavaScriptCore-1_0 >= 2.2.7-3.63
  • typelib-1_0-JavaScriptCore-3_0 >= 2.2.7-3.63
  • typelib-1_0-WebKit-1_0 >= 2.2.7-3.63
  • typelib-1_0-WebKit-3_0 >= 2.2.7-3.63
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libjavascriptcoregtk-1_0-0 >= 2.2.7-3.26
  • libwebkit2gtk-3_0-25 >= 2.2.7-3.26
  • libwebkitgtk-1_0-0 >= 2.2.7-3.26
  • libwebkitgtk-devel >= 2.2.7-3.26
  • libwebkitgtk3-devel >= 2.2.7-3.26
  • typelib-1_0-JavaScriptCore-1_0 >= 2.2.7-3.26
  • typelib-1_0-JavaScriptCore-3_0 >= 2.2.7-3.26
  • typelib-1_0-WebKit-1_0 >= 2.2.7-3.26
  • typelib-1_0-WebKit-3_0 >= 2.2.7-3.26
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libjavascriptcoregtk-1_0-0 >= 2.4.11-23.20
  • libwebkit2gtk-3_0-25 >= 2.2.7-3.26
  • libwebkitgtk-1_0-0 >= 2.4.11-23.20
  • libwebkitgtk-devel >= 2.4.11-23.20
  • libwebkitgtk3-devel >= 2.4.11-23.20
  • typelib-1_0-JavaScriptCore-1_0 >= 2.4.11-23.20
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.11-23.20
  • typelib-1_0-WebKit-1_0 >= 2.4.11-23.20
  • typelib-1_0-WebKit-3_0 >= 2.4.11-23.20
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libwebkit2gtk-3_0-25
SUSE Linux Enterprise Workstation Extension 12
  • libjavascriptcoregtk-1_0-0 >= 2.2.7-3.63
  • libjavascriptcoregtk-1_0-0-32bit >= 2.2.7-3.63
  • libwebkit2gtk-3_0-25 >= 2.2.7-3.63
  • libwebkitgtk-1_0-0 >= 2.2.7-3.63
  • libwebkitgtk-1_0-0-32bit >= 2.2.7-3.63
  • libwebkitgtk2-lang >= 2.2.7-3.63
  • typelib-1_0-JavaScriptCore-3_0 >= 2.2.7-3.63
  • typelib-1_0-WebKit-3_0 >= 2.2.7-3.63
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libjavascriptcoregtk-1_0-0 >= 2.4.8-16.2
  • libjavascriptcoregtk-1_0-0-32bit >= 2.4.8-16.2
  • libwebkit2gtk-3_0-25 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0-32bit >= 2.4.8-16.2
  • libwebkitgtk2-lang >= 2.4.8-16.2
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.8-16.2
  • typelib-1_0-WebKit-3_0 >= 2.4.8-16.2
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libjavascriptcoregtk-1_0-0 >= 2.4.11-23.20
  • libjavascriptcoregtk-1_0-0-32bit >= 2.4.11-23.20
  • libwebkit2gtk-3_0-25 >= 2.4.8-16.2
  • libwebkitgtk-1_0-0 >= 2.4.11-23.20
  • libwebkitgtk-1_0-0-32bit >= 2.4.11-23.20
  • libwebkitgtk2-lang >= 2.4.11-23.20
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.11-23.20
  • typelib-1_0-WebKit-3_0 >= 2.4.11-23.20
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libjavascriptcoregtk-1_0-0
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libwebkit2gtk-3_0-25
openSUSE 13.2
  • libjavascriptcoregtk-1_0-0 >= 2.4.6-1.4
  • libjavascriptcoregtk-3_0-0 >= 2.4.6-1.4
  • libwebkitgtk-1_0-0 >= 2.4.6-1.4
  • libwebkitgtk-3_0-0 >= 2.4.6-1.4
  • libwebkitgtk-devel >= 2.4.6-1.4
  • typelib-1_0-JavaScriptCore-1_0 >= 2.4.6-1.4
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.6-1.4
  • typelib-1_0-WebKit-1_0 >= 2.4.6-1.4
  • typelib-1_0-WebKit-3_0 >= 2.4.6-1.4
Patchnames:
openSUSE 13.2 GA libjavascriptcoregtk-1_0-0
openSUSE Leap 42.1
  • libjavascriptcoregtk-1_0-0 >= 2.4.9-4.10
  • libjavascriptcoregtk-3_0-0 >= 2.4.9-4.10
  • libwebkitgtk-1_0-0 >= 2.4.9-4.10
  • libwebkitgtk-3_0-0 >= 2.4.9-4.10
  • libwebkitgtk-devel >= 2.4.9-4.10
  • libwebkitgtk2-lang >= 2.4.9-4.10
  • libwebkitgtk3-lang >= 2.4.9-4.10
  • typelib-1_0-JavaScriptCore-1_0 >= 2.4.9-4.10
  • typelib-1_0-WebKit-1_0 >= 2.4.9-4.10
Patchnames:
openSUSE Leap 42.1 GA libjavascriptcoregtk-1_0-0
openSUSE Leap 42.2
  • libjavascriptcoregtk-1_0-0 >= 2.4.11-2.10
  • libjavascriptcoregtk-3_0-0 >= 2.4.11-2.10
  • libwebkitgtk-1_0-0 >= 2.4.11-2.10
  • libwebkitgtk-3_0-0 >= 2.4.11-2.10
  • libwebkitgtk-devel >= 2.4.11-2.10
  • libwebkitgtk2-lang >= 2.4.11-2.10
  • libwebkitgtk3-lang >= 2.4.11-2.10
  • typelib-1_0-JavaScriptCore-1_0 >= 2.4.11-2.10
  • typelib-1_0-WebKit-1_0 >= 2.4.11-2.10
Patchnames:
openSUSE Leap 42.2 GA libjavascriptcoregtk-1_0-0
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
  • libjavascriptcoregtk-1_0-0 >= 2.4.11-3.3
  • libjavascriptcoregtk-1_0-0-32bit >= 2.4.11-3.3
  • libjavascriptcoregtk-3_0-0 >= 2.4.11-3.3
  • libjavascriptcoregtk-3_0-0-32bit >= 2.4.11-3.3
  • libwebkitgtk-1_0-0 >= 2.4.11-3.3
  • libwebkitgtk-1_0-0-32bit >= 2.4.11-3.3
  • libwebkitgtk-3_0-0 >= 2.4.11-3.3
  • libwebkitgtk-3_0-0-32bit >= 2.4.11-3.3
  • libwebkitgtk-devel >= 2.4.11-3.3
  • libwebkitgtk2-lang >= 2.4.11-3.3
  • libwebkitgtk3-devel >= 2.4.11-3.3
  • libwebkitgtk3-lang >= 2.4.11-3.3
  • typelib-1_0-JavaScriptCore-1_0 >= 2.4.11-3.3
  • typelib-1_0-JavaScriptCore-3_0 >= 2.4.11-3.3
  • typelib-1_0-WebKit-1_0 >= 2.4.11-3.3
  • typelib-1_0-WebKit-3_0 >= 2.4.11-3.3
  • webkit-jsc-1 >= 2.4.11-3.3
  • webkit-jsc-3 >= 2.4.11-3.3
Patchnames:
openSUSE Tumbleweed GA chromedriver
openSUSE Tumbleweed GA libjavascriptcoregtk-1_0-0