Upstream information

CVE-2012-4528 at MITRE

Description

The mod_security2 module before 2.7.0 for the Apache HTTP Server allows remote attackers to bypass rules, and deliver arbitrary POST data to a PHP application, via a multipart request in which an invalid part precedes the crafted data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 789393 [RESOLVED / FIXED], 813190 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • apache2-mod_security2 >= 2.9.2-1.34
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA apache2-mod_security2-2.9.2-1.34
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Server Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • apache2-mod_security2 >= 2.9.2-1.34
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA apache2-mod_security2-2.9.2-1.34
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP2
  • apache2-mod_security2 >= 2.7.1-0.2.12.1
Patchnames:
sdksp2-apache2-mod_security2
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • apache2-mod_security2 >= 2.9.2-1.34
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA apache2-mod_security2-2.9.2-1.34
SUSE Linux Enterprise Server 11 SP3
  • apache2-mod_security2 >= 2.7.1-0.2.12.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA apache2-mod_security2-2.7.1-0.2.12.1
SUSE Linux Enterprise Server 11 SP4
  • apache2-mod_security2 >= 2.7.1-0.2.18.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA apache2-mod_security2-2.7.1-0.2.18.1
openSUSE Tumbleweed
  • apache2-mod_security2 >= 2.9.0-5.6
Patchnames:
openSUSE Tumbleweed GA apache2-mod_security2-2.9.0-5.6


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 apache2-mod_security2 Released
SUSE Linux Enterprise Server 11 SP2 apache2-mod_security2 Released
SUSE Linux Enterprise Server 11 SP3 apache2-mod_security2 Released
SUSE Linux Enterprise Server 11 SP3 for VMware apache2-mod_security2 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 apache2-mod_security2 Released
SUSE Linux Enterprise Software Development Kit 11 SP2 apache2-mod_security2 Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 08:50:34 2013
CVE page last modified: Tue Nov 8 17:02:40 2022