Upstream information

CVE-2012-4414 at MITRE

Description

Multiple SQL injection vulnerabilities in the replication code in Oracle MySQL possibly before 5.5.29, and MariaDB 5.1.x through 5.1.62, 5.2.x through 5.2.12, 5.3.x through 5.3.7, and 5.5.x through 5.5.25, allow remote authenticated users to execute arbitrary SQL commands via vectors related to the binary log. NOTE: as of 20130116, Oracle has not commented on claims from a downstream vendor that the fix in MySQL 5.5.29 is incomplete.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 779476 [RESOLVED / UPSTREAM]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • libmysqld-devel >= 10.2.15-1.3
  • libmysqld19 >= 10.2.15-1.3
  • mariadb >= 10.2.15-1.3
  • mariadb-client >= 10.2.15-1.3
  • mariadb-errormessages >= 10.2.15-1.3
  • mariadb-tools >= 10.2.15-1.3
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libmysqld-devel
openSUSE Leap 15.0
  • libmysqld19 >= 10.2.14-lp150.1.1
  • mariadb >= 10.2.14-lp150.1.1
  • mariadb-client >= 10.2.14-lp150.1.1
  • mariadb-errormessages >= 10.2.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libmysqld19
openSUSE Tumbleweed
  • libmysqlclient-devel >= 10.0.22-3.8
  • libmysqlclient18 >= 10.0.22-3.8
  • libmysqlclient18-32bit >= 10.0.22-3.8
  • libmysqlclient_r18 >= 10.0.22-3.8
  • libmysqlclient_r18-32bit >= 10.0.22-3.8
  • libmysqld-devel >= 10.0.22-3.8
  • libmysqld18 >= 10.0.22-3.8
  • mariadb >= 10.0.22-3.8
  • mariadb-bench >= 10.0.22-3.8
  • mariadb-client >= 10.0.22-3.8
  • mariadb-errormessages >= 10.0.22-3.8
  • mariadb-test >= 10.0.22-3.8
  • mariadb-tools >= 10.0.22-3.8
Patchnames:
openSUSE Tumbleweed GA libmysqlclient-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 mysql Affected
SUSE Linux Enterprise Desktop 10 SP4 mysql Affected
SUSE Linux Enterprise Desktop 11 SP1 mysql Released
SUSE Linux Enterprise Desktop 11 SP2 mysql Released
SUSE Linux Enterprise SDK 11 SP1 mysql Released
SUSE Linux Enterprise SDK 11 SP2 mysql Released
SUSE Linux Enterprise Server 10 SP3 mysql Affected
SUSE Linux Enterprise Server 10 SP4 mysql Affected
SUSE Linux Enterprise Server 10 SP4 LTSS mysql Affected
SUSE Linux Enterprise Server 11 SP1 mysql Released
SUSE Linux Enterprise Server 11 SP1 LTSS mysql Released
SUSE Linux Enterprise Server 11 SP2 mysql Released
SUSE Linux Enterprise Server 11 SP2 LTSS mysql Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 mysql Released
SUSE Linux Enterprise Server for VMWare 11 SP2 mysql Released