Upstream information

CVE-2012-4405 at MITRE

Description

Multiple integer underflows in the icmLut_allocate function in International Color Consortium (ICC) Format library (icclib), as used in Ghostscript 9.06 and Argyll Color Management System, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PostScript or (2) PDF file with embedded images, which triggers a heap-based buffer overflow. NOTE: this issue is also described as an array index error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 726092 [RESOLVED / NORESPONSE], 774185 [RESOLVED / FIXED], 779700 [RESOLVED / FIXED], 939342 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
sdksp2-ghostscript-devel
sledsp2-ghostscript-devel
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ghostscript-devel-8.62-32.34.1
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
sdksp2-ghostscript-devel
slessp2-ghostscript-devel
SUSE Linux Enterprise Server 11 SP3
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ghostscript-fonts-other-8.62-32.34.1
SUSE Linux Enterprise Server 11 SP4
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ghostscript-fonts-other-8.62-32.34.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ghostscript-devel-8.62-32.34.1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
sdksp2-ghostscript-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ghostscript-library Released
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP2 for VMware ghostscript-library Released
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP3 for VMware ghostscript-library Released
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP4 LTSS ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Released