Upstream information

CVE-2012-3974 at MITRE

Description

Untrusted search path vulnerability in the installer in Mozilla Firefox before 15.0, Firefox ESR 10.x before 10.0.7, Thunderbird before 15.0, and Thunderbird ESR 10.x before 10.0.7 on Windows allows local users to gain privileges via a Trojan horse executable file in a root directory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 777588 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • MozillaFirefox >= 10.0.7-0.3.1
  • MozillaFirefox-branding-SLED >= 7-0.6.7.80
  • MozillaFirefox-translations >= 10.0.7-0.3.1
  • libfreebl3 >= 3.13.6-0.5.1
  • libfreebl3-32bit >= 3.13.6-0.5.1
  • mozilla-nspr >= 4.9.2-0.6.1
  • mozilla-nspr-32bit >= 4.9.2-0.6.1
  • mozilla-nspr-devel >= 4.9.2-0.6.1
  • mozilla-nss >= 3.13.6-0.5.1
  • mozilla-nss-32bit >= 3.13.6-0.5.1
  • mozilla-nss-devel >= 3.13.6-0.5.1
  • mozilla-nss-tools >= 3.13.6-0.5.1
Patchnames:
sdksp2-firefox-201208
sledsp2-firefox-201208
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • MozillaFirefox >= 10.0.7-0.3.1
  • MozillaFirefox-branding-SLED >= 7-0.6.7.80
  • MozillaFirefox-translations >= 10.0.7-0.3.1
  • libfreebl3 >= 3.13.6-0.5.1
  • libfreebl3-32bit >= 3.13.6-0.5.1
  • libfreebl3-x86 >= 3.13.6-0.5.1
  • mozilla-nspr >= 4.9.2-0.6.1
  • mozilla-nspr-32bit >= 4.9.2-0.6.1
  • mozilla-nspr-devel >= 4.9.2-0.6.1
  • mozilla-nspr-x86 >= 4.9.2-0.6.1
  • mozilla-nss >= 3.13.6-0.5.1
  • mozilla-nss-32bit >= 3.13.6-0.5.1
  • mozilla-nss-devel >= 3.13.6-0.5.1
  • mozilla-nss-tools >= 3.13.6-0.5.1
  • mozilla-nss-x86 >= 3.13.6-0.5.1
Patchnames:
sdksp2-firefox-201208
slessp2-firefox-201208
SUSE Linux Enterprise Software Development Kit 11 SP2
  • mozilla-nspr-devel >= 4.9.2-0.6.1
  • mozilla-nss-devel >= 3.13.6-0.5.1
Patchnames:
sdksp2-firefox-201208


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4-LTSS MozillaFirefox Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 MozillaFirefox Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 13:01:56 2013
CVE page last modified: Tue Jan 17 12:14:34 2023