Upstream information

CVE-2012-3498 at MITRE

Description

PHYSDEVOP_map_pirq in Xen 4.1 and 4.2 and Citrix XenServer 6.0.2 and earlier allows local HVM guest OS kernels to cause a denial of service (host crash) and possibly read hypervisor or guest memory via vectors related to a missing range check of map->index.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.6
Vector AV:L/AC:L/Au:N/C:P/I:N/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 777086 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • vm-install >= 0.5.12-0.5.3
  • xen >= 4.1.3_02-0.5.1
  • xen-doc-html >= 4.1.3_02-0.5.1
  • xen-doc-pdf >= 4.1.3_02-0.5.1
  • xen-kmp-default >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-kmp-trace >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-libs >= 4.1.3_02-0.5.1
  • xen-libs-32bit >= 4.1.3_02-0.5.1
  • xen-tools >= 4.1.3_02-0.5.1
  • xen-tools-domU >= 4.1.3_02-0.5.1
Patchnames:
sledsp2-xen-201209
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • vm-install >= 0.5.12-0.5.3
  • xen >= 4.1.3_02-0.5.1
  • xen-doc-html >= 4.1.3_02-0.5.1
  • xen-doc-pdf >= 4.1.3_02-0.5.1
  • xen-kmp-default >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-kmp-trace >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-libs >= 4.1.3_02-0.5.1
  • xen-libs-32bit >= 4.1.3_02-0.5.1
  • xen-tools >= 4.1.3_02-0.5.1
  • xen-tools-domU >= 4.1.3_02-0.5.1
Patchnames:
slessp2-xen-201209
SUSE Linux Enterprise Server 11 SP3
  • xen >= 4.2.2_04-0.7.5
  • xen-doc-html >= 4.2.2_04-0.7.5
  • xen-doc-pdf >= 4.2.2_04-0.7.5
  • xen-kmp-default >= 4.2.2_04_3.0.76_0.11-0.7.5
  • xen-kmp-pae >= 4.2.2_04_3.0.76_0.11-0.7.5
  • xen-libs >= 4.2.2_04-0.7.5
  • xen-libs-32bit >= 4.2.2_04-0.7.5
  • xen-tools >= 4.2.2_04-0.7.5
  • xen-tools-domU >= 4.2.2_04-0.7.5
SUSE Linux Enterprise Server 11 SP4
  • xen >= 4.4.2_08-1.7
  • xen-doc-html >= 4.4.2_08-1.7
  • xen-kmp-default >= 4.4.2_08_3.0.101_63-1.7
  • xen-kmp-pae >= 4.4.2_08_3.0.101_63-1.7
  • xen-libs >= 4.4.2_08-1.7
  • xen-libs-32bit >= 4.4.2_08-1.7
  • xen-tools >= 4.4.2_08-1.7
  • xen-tools-domU >= 4.4.2_08-1.7
SUSE Linux Enterprise Server for VMWare 11 SP2
  • vm-install >= 0.5.12-0.5.1
  • xen >= 4.1.3_02-0.5.1
  • xen-doc-html >= 4.1.3_02-0.5.1
  • xen-doc-pdf >= 4.1.3_02-0.5.1
  • xen-kmp-default >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-kmp-trace >= 4.1.3_02_3.0.38_0.5-0.5.1
  • xen-libs >= 4.1.3_02-0.5.1
  • xen-libs-32bit >= 4.1.3_02-0.5.1
  • xen-tools >= 4.1.3_02-0.5.1
  • xen-tools-domU >= 4.1.3_02-0.5.1
Patchnames:
slessp2-xen-201209
SUSE Linux Enterprise Software Development Kit 11 SP2
  • xen-devel >= 4.1.3_02-0.5.1
Patchnames:
sdksp2-xen-201209
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xen-devel >= 4.4.2_08-1.7


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 xen Released
SLED-10-SP4 xen Released
SLES-10-SP3 xen Released
SLES-10-SP4 xen Released
SLES_LTSS-10-SP4 xen Released
SUSE Linux Enterprise Desktop 11 SP1 xen Unsupported
SUSE Linux Enterprise Desktop 11 SP2 xen Released
SUSE Linux Enterprise Server 11 SP1 xen Released
SUSE Linux Enterprise Server 11 SP1 LTSS xen Released
SUSE Linux Enterprise Server 11 SP2 xen Released
SUSE Linux Enterprise Server 11 SP2 LTSS xen Released
SUSE Linux Enterprise Server 11 SP2 for VMware xen Released
SUSE Linux Enterprise Server for SAP Business All-in-One xen Released
SUSE Linux Enterprise Software Development Kit 11 SP1 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP2 xen Released