Upstream information

CVE-2012-3409 at MITRE

Description

ecryptfs-utils: suid helper does not restrict mounting filesystems with nosuid,nodev which creates a possible privilege escalation

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1161332 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 ecryptfs-utils Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 ecryptfs-utils Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 ecryptfs-utils Already fixed
SUSE Linux Enterprise Module for Basesystem 15 ecryptfs-utils Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS ecryptfs-utils Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS ecryptfs-utils Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS ecryptfs-utils Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS ecryptfs-utils Already fixed
SUSE Linux Enterprise Server 12 SP4 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server 12 SP5 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ecryptfs-utils Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ecryptfs-utils Already fixed