Upstream information

CVE-2012-2944 at MITRE

Description

Buffer overflow in the addchar function in common/parseconf.c in upsd in Network UPS Tools (NUT) before 2.6.4 allows remote attackers to execute arbitrary code or cause a denial of service (electric-power outage) via a long string containing non-printable characters.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 764699 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA libupsclient1-2.7.4-4.72
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA nut-2.7.4-4.72
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA nut-2.7.4-4.72
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libupsclient1 >= 2.6.2-0.2.4.1
  • nut >= 2.6.2-0.2.4.1
  • nut-cgi >= 2.6.2-0.2.4.1
  • nut-classic >= 2.6.2-0.2.4.1
  • nut-devel >= 2.6.2-0.2.4.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libupsclient1-2.6.2-0.2.4.1
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA nut-cgi-2.7.1-4.84
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA nut-cgi-2.7.1-4.55
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA nut-cgi-2.7.1-4.55
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • nut-cgi >= 2.7.1-1.30
  • nut-devel >= 2.7.1-1.30
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nut-cgi-2.7.1-1.30
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Software Development Kit 12
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA nut-cgi-2.7.1-4.84
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libupsclient1 >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libupsclient1 >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libupsclient1 >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libupsclient1 >= 2.7.4-3.3.1
  • nut >= 2.7.4-3.3.1
  • nut-drivers-net >= 2.7.4-3.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libupsclient1-2.7.4-3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA nut-2.7.4-4.72
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libupsclient1-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP2 GA nut-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA nut-2.7.4-4.72
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • nut >= 2.7.4-4.72
  • nut-devel >= 2.7.4-4.72
  • nut-drivers-net >= 2.7.4-4.72
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA nut-2.7.4-4.72
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libupsclient1 >= 2.6.2-0.2.4.1
  • nut >= 2.6.2-0.2.4.1
  • nut-classic >= 2.6.2-0.2.4.1
  • nut-drivers-net >= 2.6.2-0.2.4.1
Patchnames:
slessp1-libupsclient1
SUSE Linux Enterprise Server 11 SP3
  • libupsclient1 >= 2.6.2-0.2.4.1
  • nut >= 2.6.2-0.2.4.1
  • nut-classic >= 2.6.2-0.2.4.1
  • nut-drivers-net >= 2.6.2-0.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libupsclient1-2.6.2-0.2.4.1
SUSE Linux Enterprise Server 11 SP4
  • libupsclient1 >= 2.6.2-0.2.4.1
  • nut >= 2.6.2-0.2.4.1
  • nut-cgi >= 2.6.2-0.2.4.1
  • nut-classic >= 2.6.2-0.2.4.1
  • nut-devel >= 2.6.2-0.2.4.1
  • nut-drivers-net >= 2.6.2-0.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libupsclient1-2.6.2-0.2.4.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libupsclient1-2.6.2-0.2.4.1
SUSE Linux Enterprise Server 12 SP1
  • libupsclient1 >= 2.7.1-4.84
  • nut >= 2.7.1-4.84
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
  • nut-drivers-net >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libupsclient1-2.7.1-4.84
SUSE Linux Enterprise Software Development Kit 12 SP1 GA nut-cgi-2.7.1-4.84
SUSE Linux Enterprise Server 12 SP2
  • libupsclient1 >= 2.7.1-4.84
  • nut >= 2.7.1-4.84
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
  • nut-drivers-net >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libupsclient1-2.7.1-4.55
SUSE Linux Enterprise Software Development Kit 12 SP2 GA nut-cgi-2.7.1-4.55
SUSE Linux Enterprise Server 12 SP3
  • libupsclient1 >= 2.7.1-4.84
  • nut >= 2.7.1-4.84
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
  • nut-drivers-net >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libupsclient1-2.7.1-4.55
SUSE Linux Enterprise Software Development Kit 12 SP3 GA nut-cgi-2.7.1-4.55
SUSE Linux Enterprise Server 12 SP4
  • libupsclient1 >= 2.7.1-1.30
  • nut >= 2.7.1-1.30
  • nut-cgi >= 2.7.1-1.30
  • nut-devel >= 2.7.1-1.30
  • nut-drivers-net >= 2.7.1-1.30
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libupsclient1-2.7.1-1.30
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nut-cgi-2.7.1-1.30
SUSE Linux Enterprise Server 12 SP5
  • libupsclient1 >= 2.7.4-3.3.1
  • nut >= 2.7.4-3.3.1
  • nut-cgi >= 2.7.4-3.3.1
  • nut-devel >= 2.7.4-3.3.1
  • nut-drivers-net >= 2.7.4-3.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libupsclient1-2.7.4-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA nut-cgi-2.7.4-3.3.1
SUSE Linux Enterprise Server 12
  • libupsclient1 >= 2.7.1-4.84
  • nut >= 2.7.1-4.84
  • nut-cgi >= 2.7.1-4.84
  • nut-devel >= 2.7.1-4.84
  • nut-drivers-net >= 2.7.1-4.84
Patchnames:
SUSE Linux Enterprise Server 12 GA libupsclient1-2.7.1-4.55
SUSE Linux Enterprise Software Development Kit 12 GA nut-cgi-2.7.1-4.84
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libupsclient1 >= 2.7.1-4.55
  • nut >= 2.7.1-4.55
  • nut-drivers-net >= 2.7.1-4.55
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libupsclient1-2.7.1-4.55
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • nut-cgi >= 2.7.4-3.3.1
  • nut-devel >= 2.7.4-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA nut-cgi-2.7.4-3.3.1
openSUSE Leap 15.0
  • libupsclient1 >= 2.7.4-lp150.3.24
  • nut >= 2.7.4-lp150.3.24
Patchnames:
openSUSE Leap 15.0 GA libupsclient1-2.7.4-lp150.3.24
openSUSE Leap 15.3
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-cgi >= 2.7.4-4.72
Patchnames:
openSUSE Leap 15.3 GA libupsclient1-2.7.4-4.72
openSUSE Leap 15.4
  • libupsclient1 >= 2.7.4-4.72
  • nut >= 2.7.4-4.72
  • nut-cgi >= 2.7.4-4.72
Patchnames:
openSUSE Leap 15.4 GA libupsclient1-2.7.4-4.72
openSUSE Tumbleweed
  • libupsclient1 >= 2.7.3-2.7
  • nut >= 2.7.3-2.7
  • nut-cgi >= 2.7.3-2.7
  • nut-devel >= 2.7.3-2.7
  • nut-drivers-net >= 2.7.3-2.7
Patchnames:
openSUSE Tumbleweed GA libupsclient1-2.7.3-2.7


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 nut Released
SUSE Linux Enterprise Desktop 11 SP4 nut Affected
SUSE Linux Enterprise Server 11 SP1 nut Released
SUSE Linux Enterprise Server 11 SP1 LTSS nut Released
SUSE Linux Enterprise Server 11 SP3 nut Affected
SUSE Linux Enterprise Server 11 SP3-LTSS nut Affected
SUSE Linux Enterprise Server 11 SP4 nut Affected
SUSE Linux Enterprise Server 11 SP4-LTSS nut Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 nut Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 nut Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 nut Released
SUSE Linux Enterprise Software Development Kit 11 SP1 nut Released
SUSE Linux Enterprise Software Development Kit 11 SP4 nut Affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 08:38:00 2013
CVE page last modified: Tue Nov 29 12:19:48 2022