CVE-2012-2840
SUSE Linux Enterprise Desktop 11 SP1,SUSE Linux Enterprise Desktop 11 SP2,SUSE Linux Enterprise Server 11 SP1,SUSE Linux Enterprise Server 11 SP1 for VMware,SUSE Linux Enterprise Server 11 SP2,SUSE Linux Enterprise Software Development Kit 11 SP1,SUSE Linux Enterprise Software Development Kit 11 SP2
CVE-2012-2840, security advisory, novell, suse linux, suse, security, cve

CVE-2012-2840

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2840 at MITRE

Description

Off-by-one error in the exif_convert_utf16_to_utf8 function in exif-entry.c in the EXIF Tag Parsing Library (aka libexif) before 0.6.21 allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted EXIF tags in an image.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 771229 [CLOSED / FIXED], 831515

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libexif-devel >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
  • libexif-32bit >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
  • libexif-x86 >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
openSUSE 11.4
  • libexif >= 0.6.20-10.1
  • libexif-debugsource >= 0.6.20-10.1
  • libexif-devel >= 0.6.20-10.1
  • libexif12 >= 0.6.20-10.1
  • libexif12-32bit >= 0.6.20-10.1
  • libexif12-debuginfo >= 0.6.20-10.1
  • libexif12-debuginfo-32bit >= 0.6.20-10.1
  • libexif12-debuginfo-x86 >= 0.6.20-10.1
  • libexif12-x86 >= 0.6.20-10.1
Patchnames:
openSUSE-2012-440