Upstream information

CVE-2012-2751 at MITRE

Description

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 768293 [VERIFIED / WONTFIX]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • apache2-mod_security2 >= 2.9.2-1.34
SUSE Linux Enterprise Server 11 SP3
  • apache2-mod_security2 >= 2.7.1-0.2.12.1
SUSE Linux Enterprise Server 11 SP4
  • apache2-mod_security2 >= 2.7.1-0.2.18.1
openSUSE Tumbleweed
  • apache2-mod_security2 >= 2.9.0-5.6
Patchnames:
openSUSE Tumbleweed GA apache2-mod_security2-2.9.0-5.6