Upstream information

CVE-2012-2661 at MITRE

Description

The Active Record component in Ruby on Rails 3.0.x before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage unintended recursion, a related issue to CVE-2012-2695.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 765074 [RESOLVED / FIXED], 766792 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP2
  • rubygem-actionpack-2_3 >= 2.3.14-0.10.1
  • rubygem-activerecord-2_3 >= 2.3.14-0.10.1
Patchnames:
sdksp2-rubygem-actionpack-2_3
sdksp2-rubygem-activerecord-2_3
SUSE Linux Enterprise Software Development Kit 11 SP4
  • rubygem-activerecord-3_2 >= 3.2.12-0.11.1
SUSE Studio Onsite Runner 1.2
  • rubygem-activerecord-2_3 >= 2.3.14-0.7.6.1
Patchnames:
slestso12-rubygem-activerecord-2_3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Software Development Kit 11 SP1 rubygem-actionpack-2_3 Released
SUSE Linux Enterprise Software Development Kit 11 SP2 rubygem-actionpack-2_3 Released