Upstream information

CVE-2012-2663 at MITRE

Description

extensions/libxt_tcp.c in iptables through 1.4.21 does not match TCP SYN+FIN packets in --syn rules, which might allow remote attackers to bypass intended firewall restrictions via crafted packets. NOTE: the CVE-2012-6638 fix makes this issue less relevant.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 765102 [RESOLVED / FIXED], 765488 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • btrfs-kmp-default >= 0_2.6.32.59_0.7-0.3.107
  • btrfs-kmp-pae >= 0_2.6.32.59_0.7-0.3.107
  • btrfs-kmp-xen >= 0_2.6.32.59_0.7-0.3.107
  • ext4dev-kmp-default >= 0_2.6.32.59_0.7-7.9.74
  • ext4dev-kmp-pae >= 0_2.6.32.59_0.7-7.9.74
  • ext4dev-kmp-ppc64 >= 0_2.6.32.59_0.7-7.9.74
  • ext4dev-kmp-trace >= 0_2.6.32.59_0.7-7.9.74
  • ext4dev-kmp-xen >= 0_2.6.32.59_0.7-7.9.74
  • hyper-v-kmp-default >= 0_2.6.32.59_0.7-0.18.20
  • hyper-v-kmp-pae >= 0_2.6.32.59_0.7-0.18.20
  • hyper-v-kmp-trace >= 0_2.6.32.59_0.7-0.18.20
  • iscsitarget-kmp-default >= 1.4.19_2.6.32.19_0.3-0.7.8
  • kernel-default >= 2.6.32.59-0.7.1
  • kernel-default-base >= 2.6.32.59-0.7.1
  • kernel-default-debuginfo >= 2.6.32.54-0.7.TDC.1
  • kernel-default-debugsource >= 2.6.32.54-0.7.TDC.1
  • kernel-default-devel >= 2.6.32.59-0.7.1
  • kernel-default-devel-debuginfo >= 2.6.32.54-0.7.TDC.1
  • kernel-default-man >= 2.6.32.59-0.15.2
  • kernel-ec2 >= 2.6.32.59-0.7.1
  • kernel-ec2-base >= 2.6.32.59-0.7.1
  • kernel-ec2-devel >= 2.6.32.59-0.7.1
  • kernel-pae >= 2.6.32.59-0.7.1
  • kernel-pae-base >= 2.6.32.59-0.7.1
  • kernel-pae-devel >= 2.6.32.59-0.7.1
  • kernel-ppc64 >= 2.6.32.59-0.7.1
  • kernel-ppc64-base >= 2.6.32.59-0.7.1
  • kernel-ppc64-devel >= 2.6.32.59-0.7.1
  • kernel-source >= 2.6.32.59-0.7.1
  • kernel-syms >= 2.6.32.59-0.7.1
  • kernel-trace >= 2.6.32.59-0.7.1
  • kernel-trace-base >= 2.6.32.59-0.7.1
  • kernel-trace-debuginfo >= 2.6.32.54-0.7.TDC.1
  • kernel-trace-debugsource >= 2.6.32.54-0.7.TDC.1
  • kernel-trace-devel >= 2.6.32.59-0.7.1
  • kernel-trace-devel-debuginfo >= 2.6.32.54-0.7.TDC.1
  • kernel-xen >= 2.6.32.59-0.7.1
  • kernel-xen-base >= 2.6.32.59-0.7.1
  • kernel-xen-debuginfo >= 2.6.32.54-0.7.TDC.1
  • kernel-xen-debugsource >= 2.6.32.54-0.7.TDC.1
  • kernel-xen-devel >= 2.6.32.59-0.7.1
  • kernel-xen-devel-debuginfo >= 2.6.32.54-0.7.TDC.1
  • oracleasm-kmp-default >= 2.0.5_2.6.32.19_0.3-7.10.1
  • xen-kmp-default >= 4.0.3_21548_16_2.6.32.59_0.15-0.5.26
  • xen-kmp-pae >= 4.0.3_21548_16_2.6.32.59_0.15-0.5.26
  • xen-kmp-trace >= 4.0.3_21548_16_2.6.32.59_0.15-0.5.26
Patchnames:
slessp1-kernel
SUSE Linux Enterprise Server 11 SP3
  • kernel-default >= 3.0.76-0.11.1
  • kernel-default-base >= 3.0.76-0.11.1
  • kernel-default-devel >= 3.0.76-0.11.1
  • kernel-default-man >= 3.0.76-0.11.1
  • kernel-pae >= 3.0.76-0.11.1
  • kernel-pae-base >= 3.0.76-0.11.1
  • kernel-pae-devel >= 3.0.76-0.11.1
  • kernel-ppc64 >= 3.0.76-0.11.1
  • kernel-ppc64-base >= 3.0.76-0.11.1
  • kernel-ppc64-devel >= 3.0.76-0.11.1
  • kernel-source >= 3.0.76-0.11.1
  • kernel-syms >= 3.0.76-0.11.1
  • kernel-trace >= 3.0.76-0.11.1
  • kernel-trace-base >= 3.0.76-0.11.1
  • kernel-trace-devel >= 3.0.76-0.11.1
  • kernel-xen >= 3.0.76-0.11.1
  • kernel-xen-base >= 3.0.76-0.11.1
  • kernel-xen-devel >= 3.0.76-0.11.1
SUSE Linux Enterprise Server 11 SP4
  • kernel-default >= 3.0.101-63.1
  • kernel-default-base >= 3.0.101-63.1
  • kernel-default-devel >= 3.0.101-63.1
  • kernel-default-man >= 3.0.101-63.1
  • kernel-pae >= 3.0.101-63.1
  • kernel-pae-base >= 3.0.101-63.1
  • kernel-pae-devel >= 3.0.101-63.1
  • kernel-ppc64 >= 3.0.101-63.1
  • kernel-ppc64-base >= 3.0.101-63.1
  • kernel-ppc64-devel >= 3.0.101-63.1
  • kernel-source >= 3.0.101-63.1
  • kernel-syms >= 3.0.101-63.1
  • kernel-trace >= 3.0.101-63.1
  • kernel-trace-base >= 3.0.101-63.1
  • kernel-trace-devel >= 3.0.101-63.1
  • kernel-xen >= 3.0.101-63.1
  • kernel-xen-base >= 3.0.101-63.1
  • kernel-xen-devel >= 3.0.101-63.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • kernel-docs >= 3.0.101-63.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 iptables Already fixed
SUSE Linux Enterprise Server 11 SP2 iptables Already fixed
SUSE Linux Enterprise Server 11 SP2 LTSS iptables Already fixed
SUSE Linux Enterprise Server 11 SP2 for VMware iptables Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 iptables Already fixed