Upstream information

CVE-2012-2122 at MITRE

Description

sql/password.c in Oracle MySQL 5.1.x before 5.1.63, 5.5.x before 5.5.24, and 5.6.x before 5.6.6, and MariaDB 5.1.x before 5.1.62, 5.2.x before 5.2.12, 5.3.x before 5.3.6, and 5.5.x before 5.5.23, when running in certain environments with certain implementations of the memcmp function, allows remote attackers to bypass authentication by repeatedly authenticating with the same incorrect password, which eventually causes a token comparison to succeed due to an improperly-checked return value.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

Note from the SUSE Security Team

To exploit this security issue, a hardware optimized memcmp is necessary. Our SUSE Linux Enterprise products so far did not ship optimized memcmp functions, so while the buggy code exists in mysql on SUSE Linux Enterprise, it is not affected by this security problem.

openSUSE versions of mariadb or mysql-community-server or other mysql derivatives are affected however.

SUSE Bugzilla entries: 765092 [RESOLVED / FIXED], 766428 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysqlclient-devel-5.0.96-0.6.1
SUSE Linux Enterprise Server 11 SP1
  • libmysqlclient15 >= 5.0.96-0.4.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.4.1
  • libmysqlclient_r15 >= 5.0.96-0.4.1
  • mysql >= 5.0.96-0.4.1
  • mysql-Max >= 5.0.96-0.4.1
  • mysql-client >= 5.0.96-0.4.1
  • mysql-tools >= 5.0.96-0.4.1
Patchnames:
slessp1-libmysqlclient-devel
SUSE Linux Enterprise Server 11 SP2
  • libmysqlclient15 >= 5.0.96-0.4.1
  • libmysqlclient15-32bit >= 5.0.96-0.4.1
  • libmysqlclient15-x86 >= 5.0.96-0.4.1
  • libmysqlclient_r15 >= 5.0.96-0.4.1
  • mysql >= 5.0.96-0.4.1
  • mysql-Max >= 5.0.96-0.4.1
  • mysql-client >= 5.0.96-0.4.1
  • mysql-tools >= 5.0.96-0.4.1
Patchnames:
slessp1-libmysqlclient-devel
SUSE Linux Enterprise Server 11 SP3
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • mysql >= 5.5.31-0.7.10
  • mysql-client >= 5.5.31-0.7.10
  • mysql-tools >= 5.5.31-0.7.10
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libmysqlclient15-32bit-5.0.96-0.6.1
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient15 >= 5.0.96-0.6.20
  • libmysqlclient15-32bit >= 5.0.96-0.6.20
  • libmysqlclient15-x86 >= 5.0.96-0.6.20
  • libmysqlclient_r15 >= 5.0.96-0.6.20
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libmysql55client18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Server 11 SP4 GA libmysqlclient15-32bit-5.0.96-0.6.20
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysqlclient-devel-5.0.96-0.6.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP1 mysql Released
SUSE Linux Enterprise Desktop 11 SP4 mysql Affected
SUSE Linux Enterprise Server 11 SP1 mysql Released
SUSE Linux Enterprise Server 11 SP1 LTSS mysql Released
SUSE Linux Enterprise Server 11 SP3 mysql Affected
SUSE Linux Enterprise Server 11 SP3-LTSS mysql Affected
SUSE Linux Enterprise Server 11 SP4 mysql Affected
SUSE Linux Enterprise Server 11 SP4-LTSS mysql Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 mysql Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 mysql Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 mysql Released
SUSE Linux Enterprise Software Development Kit 11 SP1 mysql Released
SUSE Linux Enterprise Software Development Kit 11 SP4 mysql Affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 08:38:25 2013
CVE page last modified: Tue Jan 17 12:11:41 2023