CVE-2012-1015
CVE-2012-1015, security advisory, novell, suse linux, suse, security, cve

CVE-2012-1015

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-1015 at MITRE

Description

The kdc_handle_protected_negotiation function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8.x, 1.9.x before 1.9.5, and 1.10.x before 1.10.3 attempts to calculate a checksum before verifying that the key type is appropriate for a checksum, which allows remote attackers to execute arbitrary code or cause a denial of service (uninitialized pointer free, heap memory corruption, and daemon crash) via a crafted AS-REQ request.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.33
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 770172 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.4
  • krb5 >= 1.8.3-52.1
  • krb5-32bit >= 1.8.3-52.1
  • krb5-client >= 1.8.3-52.1
  • krb5-client-debuginfo >= 1.8.3-52.1
  • krb5-debuginfo >= 1.8.3-52.1
  • krb5-debuginfo-32bit >= 1.8.3-52.1
  • krb5-debuginfo-x86 >= 1.8.3-52.1
  • krb5-debugsource >= 1.8.3-52.1
  • krb5-devel >= 1.8.3-52.1
  • krb5-devel-32bit >= 1.8.3-52.1
  • krb5-plugin-kdb-ldap >= 1.8.3-52.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.8.3-52.1
  • krb5-plugin-preauth-pkinit >= 1.8.3-52.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.8.3-52.1
  • krb5-server >= 1.8.3-52.1
  • krb5-server-debuginfo >= 1.8.3-52.1
  • krb5-x86 >= 1.8.3-52.1
Patchnames:
openSUSE-2012-497