Upstream information

CVE-2012-0804 at MITRE

Description

Heap-based buffer overflow in the proxy_connect function in src/client.c in CVS 1.11 and 1.12 allows remote HTTP proxy servers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted HTTP response.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 744059 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • cvs >= 1.12.12-182.3.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
  • cvs >= 1.12.12-181.63
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • cvs >= 1.12.12-182.3.1
  • cvs-doc >= 1.12.12-182.3.1
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Module for Development Tools 15 SP1
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • cvs >= 1.12.12-2.30
SUSE Linux Enterprise Server 11 SP1
  • cvs >= 1.12.12-144.23.5.1
  • cvs-doc >= 1.12.12-144.23.5.1
Patchnames:
slessp1-cvs
SUSE Linux Enterprise Server 11 SP2
  • cvs >= 1.12.12-144.23.5.1
  • cvs-doc >= 1.12.12-144.23.5.1
Patchnames:
slessp1fsp2-cvs
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • cvs >= 1.12.12-144.23.5.1
  • cvs-doc >= 1.12.12-144.23.5.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • cvs >= 1.12.12-181.63
  • cvs-doc >= 1.12.12-181.63
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • cvs >= 1.12.12-181.54
  • cvs-doc >= 1.12.12-181.54
SUSE Linux Enterprise Software Development Kit 11 SP4
  • cvs-doc >= 1.12.12-144.23.5.1
openSUSE Tumbleweed
  • cvs >= 1.12.12-183.10
  • cvs-doc >= 1.12.12-183.10
Patchnames:
openSUSE Tumbleweed GA cvs-1.12.12-183.10


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 cvs Released
SLED-10-SP4 cvs Released
SLES-10-SP3 cvs Released
SLES-10-SP4 cvs Released
SLES_LTSS-10-SP4 cvs Released
SUSE Linux Enterprise Desktop 11 SP1 cvs Released
SUSE Linux Enterprise Server 11 SP1 cvs Released
SUSE Linux Enterprise Server 11 SP1 LTSS cvs Released
SUSE Linux Enterprise Server for SAP Business All-in-One cvs Released
SUSE Linux Enterprise Software Development Kit 11 SP1 cvs Released