Upstream information

CVE-2011-4355 at MITRE

Description

GNU Project Debugger (GDB) before 7.5, when .debug_gdb_scripts is defined, automatically loads certain files from the current working directory, which allows local users to gain privileges via crafted files such as Python scripts.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Note from the SUSE Security Team

The problem affects SUSE Linux Enterprise, but a usage scenario where an administrator runs gdb in untrusted attacker controlled directories is very unlikely.

SUSE Bugzilla entry: 733300 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications gdb Affected
SUSE CaaS Platform 4.5 gdb Not affected
SUSE Enterprise Storage 7 gdb Not affected
SUSE Linux Enterprise Desktop 11 SP1 gdb Affected
SUSE Linux Enterprise Desktop 11 SP2 gdb Affected
SUSE Linux Enterprise Desktop 15 SP3 gdb Not affected
SUSE Linux Enterprise Desktop 15 SP4 gdb Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search gdb Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS gdb Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS gdb Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS gdb Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gdb Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gdb Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 gdb Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 gdb Not affected
SUSE Linux Enterprise Real Time 15 SP2 gdb Not affected
SUSE Linux Enterprise Server 11 SP1 gdb Affected
SUSE Linux Enterprise Server 11 SP1 LTSS gdb Affected
SUSE Linux Enterprise Server 11 SP2 gdb Affected
SUSE Linux Enterprise Server 11 SP2 LTSS gdb Affected
SUSE Linux Enterprise Server 11 SP2 for VMware gdb Affected
SUSE Linux Enterprise Server 12 SP2 BCL gdb Not affected
SUSE Linux Enterprise Server 12 SP3 BCL gdb Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS gdb Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS gdb Not affected
SUSE Linux Enterprise Server 15 SP3 gdb Not affected
SUSE Linux Enterprise Server 15 SP4 gdb Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gdb Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 gdb Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 gdb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gdb Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gdb Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gdb Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gdb Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 gdb Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 gdb Affected
SUSE Linux Enterprise Storage 7.1 gdb Not affected
SUSE Manager Proxy 4.1 gdb Not affected
SUSE Manager Proxy 4.2 gdb Not affected
SUSE Manager Proxy 4.3 gdb Not affected
SUSE Manager Retail Branch Server 4.1 gdb Not affected
SUSE Manager Retail Branch Server 4.2 gdb Not affected
SUSE Manager Retail Branch Server 4.3 gdb Not affected
SUSE Manager Server 4.1 gdb Not affected
SUSE Manager Server 4.2 gdb Not affected
SUSE Manager Server 4.3 gdb Not affected
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
gdbNot affected