Upstream information

CVE-2011-3848 at MITRE

Description

Directory traversal vulnerability in Puppet 2.6.x before 2.6.10 and 2.7.x before 2.7.4 allows remote attackers to write X.509 Certificate Signing Request (CSR) to arbitrary locations via (1) a double-encoded key parameter in the URI in 2.7.x, (2) the CN in the Subject of a CSR in 2.6 and 0.25.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 721139 [RESOLVED / FIXED], 726372 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • puppet >= 3.8.5-5.1
SUSE Linux Enterprise Desktop 12 SP3
  • puppet >= 3.8.5-14.1
SUSE Linux Enterprise Desktop 12 SP4
  • puppet >= 3.8.5-15.9.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
  • puppet >= 3.6.2-3.62
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • puppet >= 3.6.2-3.62
  • puppet-server >= 3.6.2-3.62
SUSE Linux Enterprise Server 11 SP1
  • puppet >= 2.6.12-0.6.1
  • puppet-server >= 2.6.12-0.6.1
  • pwdutils >= 3.2.8-0.2.35
Patchnames:
slessp1-puppet
SUSE Linux Enterprise Server 11 SP2
  • puppet >= 2.6.12-0.10.1
  • puppet-server >= 2.6.12-0.10.1
SUSE Linux Enterprise Server 11 SP3
  • puppet >= 2.6.18-0.4.2
  • puppet-server >= 2.6.18-0.4.2
SUSE Linux Enterprise Server 11 SP4
  • puppet >= 2.7.26-0.5.1
  • puppet-server >= 2.7.26-0.5.1
openSUSE Tumbleweed
  • ruby2.2-rubygem-puppet >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-2.2
  • rubygem-puppet >= 3.8.7-2.2
  • rubygem-puppet-emacs >= 3.8.7-2.2
  • rubygem-puppet-master >= 3.8.7-2.2
  • rubygem-puppet-master-unicorn >= 3.8.7-2.2
  • rubygem-puppet-vim >= 3.8.7-2.2
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-puppet


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 puppet Released
SUSE Linux Enterprise Server 11 SP1 puppet Released
SUSE Linux Enterprise Server 11 SP1 LTSS puppet Released
SUSE Linux Enterprise Server for SAP Business All-in-One puppet Released