Upstream information

CVE-2011-3464 at MITRE

Description

Off-by-one error in the png_formatted_warning function in pngerror.c in libpng 1.5.4 through 1.5.7 might allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via unspecified vectors, which trigger a stack-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 745029 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • libpng15-15 >= 1.5.22-2.2
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpng15-15 >= 1.5.22-4.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libpng15-15 >= 1.5.22-9.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libpng15 Already fixed
SLES for SAP Applications libpng12-0 Already fixed
SUSE Linux Enterprise Desktop 12 SP3 libpng12 Already fixed
SUSE Linux Enterprise Desktop 12 SP4 libpng12 Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 libpng12 Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 libpng15 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 libpng12 Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS libpng12-0 Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS libpng12-0 Already fixed
SUSE Linux Enterprise Server 12 LTSS libpng12 Already fixed
SUSE Linux Enterprise Server 12 SP1 LTSS libpng12 Already fixed
SUSE Linux Enterprise Server 12 SP2 BCL libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS libpng12 Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS SAP libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP3 libpng12 Already fixed
SUSE Linux Enterprise Server 12 SP3 BCL libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP4 libpng12 Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP5 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 libpng12 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libpng12 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libpng12 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libpng15 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 libpng12 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP4 libpng12 Already fixed
SUSE OpenStack Cloud 8 libpng15 Already fixed
SUSE OpenStack Cloud 9 libpng15 Already fixed
SUSE OpenStack Cloud Crowbar 8 libpng15 Already fixed
SUSE OpenStack Cloud Crowbar 9 libpng15 Already fixed