CVE-2011-2990
openSUSE 11.3,openSUSE 11.4
CVE-2011-2990, security advisory, novell, suse linux, suse, security, cve

CVE-2011-2990

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-2990 at MITRE

Description

The implementation of Content Security Policy (CSP) violation reports in Mozilla Firefox 4.x through 5, SeaMonkey 2.x before 2.3, and possibly other products does not remove proxy-authorization credentials from the listed request headers, which allows attackers to obtain sensitive information by reading a report, related to incorrect host resolution that occurs with certain redirects.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 712224 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
  • seamonkey-debuginfo >= 2.3-2.2.1
  • seamonkey-debugsource >= 2.3-2.2.1
openSUSE 11.3
openSUSE 11.4
  • seamonkey >= 2.3-2.2.1
  • seamonkey-dom-inspector >= 2.3-2.2.1
  • seamonkey-irc >= 2.3-2.2.1
  • seamonkey-translations-common >= 2.3-2.2.1
  • seamonkey-translations-other >= 2.3-2.2.1
  • seamonkey-venkman >= 2.3-2.2.1
openSUSE 11.4
  • MozillaFirefox >= 6.0-2.2.1
  • MozillaFirefox-branding-upstream >= 6.0-2.2.1
  • MozillaFirefox-buildsymbols >= 6.0-2.2.1
  • MozillaFirefox-devel >= 6.0-2.2.1
  • MozillaFirefox-translations-common >= 6.0-2.2.1
  • MozillaFirefox-translations-other >= 6.0-2.2.1
openSUSE 11.4
  • MozillaFirefox >= 6.0-2.2.1
  • MozillaFirefox-branding-upstream >= 6.0-2.2.1
  • MozillaFirefox-buildsymbols >= 6.0-2.2.1
  • MozillaFirefox-debuginfo >= 6.0-2.2.1
  • MozillaFirefox-debugsource >= 6.0-2.2.1
  • MozillaFirefox-devel >= 6.0-2.2.1
  • MozillaFirefox-translations-common >= 6.0-2.2.1
  • MozillaFirefox-translations-other >= 6.0-2.2.1
  • mozilla-js20 >= 2.0.1-0.2.2
  • mozilla-js20-32bit >= 2.0.1-0.2.2
  • mozilla-js20-debuginfo >= 2.0.1-0.2.2
  • mozilla-js20-debuginfo-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20 >= 2.0.1-0.2.2
  • mozilla-xulrunner20-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20-buildsymbols >= 2.0.1-0.2.2
  • mozilla-xulrunner20-debuginfo >= 2.0.1-0.2.2
  • mozilla-xulrunner20-debuginfo-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20-debugsource >= 2.0.1-0.2.2
  • mozilla-xulrunner20-devel >= 2.0.1-0.2.2
  • mozilla-xulrunner20-devel-debuginfo >= 2.0.1-0.2.2
  • mozilla-xulrunner20-gnome >= 2.0.1-0.2.2
  • mozilla-xulrunner20-gnome-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20-gnome-debuginfo >= 2.0.1-0.2.2
  • mozilla-xulrunner20-gnome-debuginfo-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20-translations-common >= 2.0.1-0.2.2
  • mozilla-xulrunner20-translations-common-32bit >= 2.0.1-0.2.2
  • mozilla-xulrunner20-translations-other >= 2.0.1-0.2.2
  • mozilla-xulrunner20-translations-other-32bit >= 2.0.1-0.2.2
  • seamonkey >= 2.3-2.2.1
  • seamonkey-debuginfo >= 2.3-2.2.1
  • seamonkey-debugsource >= 2.3-2.2.1
  • seamonkey-dom-inspector >= 2.3-2.2.1
  • seamonkey-irc >= 2.3-2.2.1
  • seamonkey-translations-common >= 2.3-2.2.1
  • seamonkey-translations-other >= 2.3-2.2.1
  • seamonkey-venkman >= 2.3-2.2.1
Patchnames:
MozillaFirefox
seamonkey