Upstream information

CVE-2011-2691 at MITRE

Description

The png_err function in pngerror.c in libpng 1.0.x before 1.0.55, 1.2.x before 1.2.45, 1.4.x before 1.4.8, and 1.5.x before 1.5.4 makes a function call using a NULL pointer argument instead of an empty-string argument, which allows remote attackers to cause a denial of service (application crash) via a crafted PNG image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 706388 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • libpng15-15 >= 1.5.22-2.2
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
  • libpng15-15 >= 1.5.22-4.1
  • libpng16-16 >= 1.6.8-11.1
  • libpng16-16-32bit >= 1.6.8-11.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libpng15-15 >= 1.5.22-9.1
  • libpng16-16 >= 1.6.8-14.1
  • libpng16-16-32bit >= 1.6.8-14.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server 12
  • libpng16-16 >= 1.6.8-2.24
  • libpng16-16-32bit >= 1.6.8-2.24
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpng16-16 >= 1.6.34-1.19
  • libpng16-16-32bit >= 1.6.34-1.19
  • libpng16-compat-devel >= 1.6.34-1.19
  • libpng16-devel >= 1.6.34-1.19
SUSE Linux Enterprise Server 11 SP1
  • libpng12-0 >= 1.2.31-5.25.1
  • libpng12-0-32bit >= 1.2.31-5.33.1
  • libpng12-0-x86 >= 1.2.31-5.31.1
Patchnames:
slessp1-libpng-devel
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.25.1
  • libpng12-0-32bit >= 1.2.31-5.25.1
  • libpng12-0-x86 >= 1.2.31-5.25.1
SUSE Linux Enterprise Server 11 SP3
  • libpng12-0 >= 1.2.31-5.31.1
  • libpng12-0-32bit >= 1.2.31-5.31.1
  • libpng12-0-x86 >= 1.2.31-5.31.1
SUSE Linux Enterprise Server 11 SP4
  • libpng12-0 >= 1.2.31-5.33.1
  • libpng12-0-32bit >= 1.2.31-5.33.1
  • libpng12-0-x86 >= 1.2.31-5.33.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpng15-15 >= 1.5.22-4.1
  • libpng16-16 >= 1.6.8-11.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpng-devel >= 1.2.31-5.33.1
  • libpng-devel-32bit >= 1.2.31-5.33.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpng16-compat-devel >= 1.6.8-5.1
  • libpng16-devel >= 1.6.8-5.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpng16-compat-devel >= 1.6.8-11.1
  • libpng16-devel >= 1.6.8-11.1
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpng16-compat-devel >= 1.6.8-14.1
  • libpng16-devel >= 1.6.8-14.1
SUSE Linux Enterprise Software Development Kit 12
  • libpng16-compat-devel >= 1.6.8-2.24
  • libpng16-devel >= 1.6.8-2.24
openSUSE Leap 15.0
  • libpng16-16 >= 1.6.34-lp150.1.5
Patchnames:
openSUSE Leap 15.0 GA libpng16-16-1.6.34-lp150.1.5
openSUSE Tumbleweed
  • libpng16-16 >= 1.6.26-1.1
  • libpng16-16-32bit >= 1.6.26-1.1
  • libpng16-compat-devel >= 1.6.26-1.1
  • libpng16-compat-devel-32bit >= 1.6.26-1.1
  • libpng16-devel >= 1.6.26-1.1
  • libpng16-devel-32bit >= 1.6.26-1.1
  • libpng16-tools >= 1.6.26-1.1
Patchnames:
openSUSE Tumbleweed GA libpng16-16-1.6.26-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libpng15 Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS libpng15 Already fixed
SUSE Linux Enterprise Server 12 SP5 libpng15 Already fixed
SUSE Linux Enterprise Server BCL 12 SP2 libpng15 Already fixed
SUSE Linux Enterprise Server BCL 12 SP3 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libpng15 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libpng15 Already fixed
SUSE OpenStack Cloud 8 libpng15 Already fixed
SUSE OpenStack Cloud 9 libpng15 Already fixed
SUSE OpenStack Cloud Crowbar 8 libpng15 Already fixed
SUSE OpenStack Cloud Crowbar 9 libpng15 Already fixed