Upstream information

CVE-2011-2054 at MITRE

Description

** RESERVED ** This candidate has been reserved by an organization or individual that will use it when announcing a new security problem. When the candidate has been publicized, the details for this candidate will be provided.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

SUSE Bugzilla entry: 709167 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libsoup-2_4-1 >= 2.44.2-1.46
  • libsoup-2_4-1-32bit >= 2.44.2-1.46
  • libsoup-lang >= 2.44.2-1.46
  • typelib-1_0-Soup-2_4 >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libsoup-2_4-1
SUSE Linux Enterprise Desktop 12 SP1
  • libsoup-2_4-1 >= 2.44.2-1.46
  • libsoup-2_4-1-32bit >= 2.44.2-1.46
  • libsoup-lang >= 2.44.2-1.46
  • typelib-1_0-Soup-2_4 >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libsoup-2_4-1
SUSE Linux Enterprise Desktop 12 SP2
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-2_4-1-32bit >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libsoup-2_4-1
SUSE Linux Enterprise Desktop 12 SP3
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-2_4-1-32bit >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libsoup-2_4-1
SUSE Linux Enterprise Module for Basesystem 15
  • libsoup-2_4-1 >= 2.62.2-1.9
  • libsoup-lang >= 2.62.2-1.9
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libsoup-2_4-1
SUSE Linux Enterprise Module for Desktop Applications 15
  • libsoup-devel >= 2.62.2-1.9
  • typelib-1_0-Soup-2_4 >= 2.62.2-1.9
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libsoup-devel
SUSE Linux Enterprise Server 12
  • libsoup-2_4-1 >= 2.44.2-1.46
  • libsoup-2_4-1-32bit >= 2.44.2-1.46
  • libsoup-lang >= 2.44.2-1.46
  • typelib-1_0-Soup-2_4 >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Server 12 GA libsoup-2_4-1
SUSE Linux Enterprise Server 12 SP1
  • libsoup-2_4-1 >= 2.44.2-1.46
  • libsoup-2_4-1-32bit >= 2.44.2-1.46
  • libsoup-lang >= 2.44.2-1.46
  • typelib-1_0-Soup-2_4 >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libsoup-2_4-1
SUSE Linux Enterprise Server 12 SP2
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-2_4-1-32bit >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libsoup-2_4-1
SUSE Linux Enterprise Server 12 SP3
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-2_4-1-32bit >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libsoup-2_4-1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsoup-2_4-1
SUSE Linux Enterprise Software Development Kit 12
  • libsoup-devel >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libsoup-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsoup-devel >= 2.44.2-1.46
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libsoup-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsoup-devel >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libsoup-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsoup-devel >= 2.54.1-4.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libsoup-devel
openSUSE Leap 15.0
  • libsoup-2_4-1 >= 2.62.2-lp150.1.1
  • libsoup-lang >= 2.62.2-lp150.1.1
  • typelib-1_0-Soup-2_4 >= 2.62.2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libsoup-2_4-1
openSUSE Leap 42.1
  • libsoup-2_4-1 >= 2.50.0-2.3
  • libsoup-devel >= 2.50.0-2.3
  • libsoup-lang >= 2.50.0-2.3
  • typelib-1_0-Soup-2_4 >= 2.50.0-2.3
Patchnames:
openSUSE Leap 42.1 GA libsoup-2_4-1
openSUSE Leap 42.2
  • libsoup-2_4-1 >= 2.54.1-1.5
  • libsoup-devel >= 2.54.1-1.5
  • libsoup-lang >= 2.54.1-1.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-1.5
Patchnames:
openSUSE Leap 42.2 GA libsoup-2_4-1
openSUSE Leap 42.3
  • libsoup-2_4-1 >= 2.54.1-3.4
  • libsoup-devel >= 2.54.1-3.4
  • libsoup-lang >= 2.54.1-3.4
  • typelib-1_0-Soup-2_4 >= 2.54.1-3.4
Patchnames:
openSUSE Leap 42.3 GA libsoup-2_4-1
openSUSE Tumbleweed
  • libsoup-2_4-1 >= 2.56.0-1.1
  • libsoup-2_4-1-32bit >= 2.56.0-1.1
  • libsoup-devel >= 2.56.0-1.1
  • libsoup-devel-32bit >= 2.56.0-1.1
  • libsoup-lang >= 2.56.0-1.1
  • typelib-1_0-Soup-2_4 >= 2.56.0-1.1
Patchnames:
openSUSE Tumbleweed GA libsoup-2_4-1