Upstream information

CVE-2011-2054 at MITRE

Description

A vulnerability in the Cisco ASA that could allow a remote attacker to successfully authenticate using the Cisco AnyConnect VPN client if the Secondary Authentication type is LDAP and the password is left blank, providing the primary credentials are correct. The vulnerabilities is due to improper input validation of certain parameters passed to the affected software. An attacker must have the correct primary credentials in order to successfully exploit this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 709167 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-2_4-1-32bit >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libsoup-2_4-1 >= 2.62.2-5.7.1
  • libsoup-2_4-1-32bit >= 2.62.2-5.7.1
  • libsoup-lang >= 2.62.2-5.7.1
  • typelib-1_0-Soup-2_4 >= 2.62.2-5.7.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
  • libsoup-2_4-1 >= 2.44.2-1.46
  • libsoup-2_4-1-32bit >= 2.44.2-1.46
  • libsoup-lang >= 2.44.2-1.46
  • typelib-1_0-Soup-2_4 >= 2.44.2-1.46
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libsoup-2_4-1 >= 2.62.2-3.3.32
  • libsoup-lang >= 2.62.2-3.3.32
SUSE Linux Enterprise Module for Basesystem 15
  • libsoup-2_4-1 >= 2.62.2-1.9
  • libsoup-lang >= 2.62.2-1.9
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libsoup-devel >= 2.62.2-3.3.32
  • typelib-1_0-Soup-2_4 >= 2.62.2-3.3.32
SUSE Linux Enterprise Module for Desktop Applications 15
  • libsoup-devel >= 2.62.2-1.9
  • typelib-1_0-Soup-2_4 >= 2.62.2-1.9
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsoup-2_4-1 >= 2.54.1-4.5
  • libsoup-lang >= 2.54.1-4.5
  • typelib-1_0-Soup-2_4 >= 2.54.1-4.5
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsoup-devel >= 2.54.1-4.5
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsoup-devel >= 2.62.2-5.7.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsoup-devel >= 2.44.2-1.46
openSUSE Leap 15.0
  • libsoup-2_4-1 >= 2.62.2-lp150.1.1
  • libsoup-lang >= 2.62.2-lp150.1.1
  • typelib-1_0-Soup-2_4 >= 2.62.2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libsoup-2_4-1-2.62.2-lp150.1.1
openSUSE Tumbleweed
  • libsoup-2_4-1 >= 2.56.0-1.1
  • libsoup-2_4-1-32bit >= 2.56.0-1.1
  • libsoup-devel >= 2.56.0-1.1
  • libsoup-devel-32bit >= 2.56.0-1.1
  • libsoup-lang >= 2.56.0-1.1
  • typelib-1_0-Soup-2_4 >= 2.56.0-1.1
Patchnames:
openSUSE Tumbleweed GA libsoup-2_4-1-2.56.0-1.1