Upstream information

CVE-2011-1783 at MITRE

Description

The mod_dav_svn module for the Apache HTTP Server, as distributed in Apache Subversion 1.5.x and 1.6.x before 1.6.17, when the SVNPathAuthz short_circuit option is enabled, allows remote attackers to cause a denial of service (infinite loop and memory consumption) in opportunistic circumstances by requesting data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 698205 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • subversion >= 1.10.0-3.3.1
  • subversion-devel >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • subversion >= 1.10.0-1.24
  • subversion-devel >= 1.10.0-1.24
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • subversion-bash-completion >= 1.10.0-3.3.1
  • subversion-perl >= 1.10.0-3.3.1
  • subversion-python >= 1.10.0-3.3.1
  • subversion-tools >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Development Tools 15
  • subversion-bash-completion >= 1.10.0-1.24
  • subversion-perl >= 1.10.0-1.24
  • subversion-python >= 1.10.0-1.24
  • subversion-tools >= 1.10.0-1.24
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • subversion-server >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Server Applications 15
  • subversion-server >= 1.10.0-1.24
SUSE Linux Enterprise Software Development Kit 11 SP4
  • subversion >= 1.6.17-1.33.1
  • subversion-devel >= 1.6.17-1.33.1
  • subversion-perl >= 1.6.17-1.33.1
  • subversion-python >= 1.6.17-1.33.1
  • subversion-server >= 1.6.17-1.33.1
  • subversion-tools >= 1.6.17-1.33.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-15.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-15.1
  • subversion >= 1.8.10-15.1
  • subversion-bash-completion >= 1.8.10-15.1
  • subversion-devel >= 1.8.10-15.1
  • subversion-perl >= 1.8.10-15.1
  • subversion-python >= 1.8.10-15.1
  • subversion-server >= 1.8.10-15.1
  • subversion-tools >= 1.8.10-15.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-24.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.10-24.1
  • subversion-bash-completion >= 1.8.10-24.1
  • subversion-devel >= 1.8.10-24.1
  • subversion-perl >= 1.8.10-24.1
  • subversion-python >= 1.8.10-24.1
  • subversion-server >= 1.8.10-24.1
  • subversion-tools >= 1.8.10-24.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.19-25.3.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.19-25.3.1
  • subversion-bash-completion >= 1.8.19-25.3.1
  • subversion-devel >= 1.8.19-25.3.1
  • subversion-perl >= 1.8.19-25.3.1
  • subversion-python >= 1.8.19-25.3.1
  • subversion-server >= 1.8.19-25.3.1
  • subversion-tools >= 1.8.19-25.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsvn_auth_gnome_keyring-1-0 >= 1.10.6-1.12
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.10.6-1.12
  • subversion-bash-completion >= 1.10.6-1.12
  • subversion-devel >= 1.10.6-1.12
  • subversion-perl >= 1.10.6-1.12
  • subversion-python >= 1.10.6-1.12
  • subversion-server >= 1.10.6-1.12
  • subversion-tools >= 1.10.6-1.12
SUSE Linux Enterprise Software Development Kit 12
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-1.25
  • libsvn_auth_kwallet-1-0 >= 1.8.10-1.25
  • subversion >= 1.8.10-1.25
  • subversion-bash-completion >= 1.8.10-1.25
  • subversion-devel >= 1.8.10-1.25
  • subversion-perl >= 1.8.10-1.25
  • subversion-python >= 1.8.10-1.25
  • subversion-server >= 1.8.10-1.25
  • subversion-tools >= 1.8.10-1.25
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0-1.9.5-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 subversion Released
SLED-10-SP4 subversion Released
SUSE Linux Enterprise Software Development Kit 11 SP1 subversion Released
SUSE Studio Onsite subversion Released