Upstream information

CVE-2011-1523 at MITRE

Description

Cross-site scripting (XSS) vulnerability in statusmap.c in statusmap.cgi in Nagios 3.2.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the layer parameter.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 682966 [RESOLVED / FIXED], 697895 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • nagios >= 3.0.6-1.25.36.1
  • nagios-devel >= 3.0.6-1.25.36.1
  • nagios-www >= 3.0.6-1.25.36.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA nagios-3.0.6-1.25.36.1
SUSE Linux Enterprise Server 11 SP1
  • nagios >= 3.0.6-1.23.1
  • nagios-www >= 3.0.6-1.23.1
Patchnames:
slessp1-nagios
SUSE Linux Enterprise Server 11 SP2
  • nagios >= 3.0.6-1.25.24.1
  • nagios-www >= 3.0.6-1.25.24.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA nagios-3.0.6-1.25.24.1
SUSE Linux Enterprise Server 11 SP3
  • nagios >= 3.0.6-1.25.28.1
  • nagios-www >= 3.0.6-1.25.28.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA nagios-3.0.6-1.25.28.1
SUSE Linux Enterprise Server 11 SP4
  • nagios >= 3.0.6-1.25.36.1
  • nagios-devel >= 3.0.6-1.25.36.1
  • nagios-www >= 3.0.6-1.25.36.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA nagios-3.0.6-1.25.36.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA nagios-3.0.6-1.25.36.1
openSUSE Tumbleweed
  • nagios >= 4.4.6-2.5
  • nagios-contrib >= 4.4.6-2.5
  • nagios-devel >= 4.4.6-2.5
  • nagios-theme-exfoliation >= 4.4.6-2.5
  • nagios-www >= 4.4.6-2.5
  • nagios-www-dch >= 4.4.6-2.5
Patchnames:
openSUSE Tumbleweed GA nagios-4.4.6-2.5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 nagios Released
SUSE Linux Enterprise Desktop 11 SP4 nagios Affected
SUSE Linux Enterprise Server 11 SP1 nagios Released
SUSE Linux Enterprise Server 11 SP1 LTSS nagios Released
SUSE Linux Enterprise Server 11 SP3 nagios Affected
SUSE Linux Enterprise Server 11 SP3-LTSS nagios Affected
SUSE Linux Enterprise Server 11 SP4 nagios Affected
SUSE Linux Enterprise Server 11 SP4-LTSS nagios Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 nagios Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 nagios Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 nagios Released
SUSE Linux Enterprise Software Development Kit 11 SP1 nagios Released
SUSE Linux Enterprise Software Development Kit 11 SP4 nagios Affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 07:54:30 2013
CVE page last modified: Tue Nov 29 12:06:47 2022