Upstream information

CVE-2011-1468 at MITRE

Description

Multiple memory leaks in the OpenSSL extension in PHP before 5.3.6 might allow remote attackers to cause a denial of service (memory consumption) via (1) plaintext data to the openssl_encrypt function or (2) ciphertext data to the openssl_decrypt function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 681197 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • apache2-mod_php5 >= 5.2.14-0.7.24.1
  • php5 >= 5.2.14-0.7.24.1
  • php5-bcmath >= 5.2.14-0.7.24.1
  • php5-bz2 >= 5.2.14-0.7.24.1
  • php5-calendar >= 5.2.14-0.7.24.1
  • php5-ctype >= 5.2.14-0.7.24.1
  • php5-curl >= 5.2.14-0.7.24.1
  • php5-dba >= 5.2.14-0.7.24.1
  • php5-dbase >= 5.2.14-0.7.24.1
  • php5-dom >= 5.2.14-0.7.24.1
  • php5-exif >= 5.2.14-0.7.24.1
  • php5-fastcgi >= 5.2.14-0.7.24.1
  • php5-ftp >= 5.2.14-0.7.24.1
  • php5-gd >= 5.2.14-0.7.24.1
  • php5-gettext >= 5.2.14-0.7.24.1
  • php5-gmp >= 5.2.14-0.7.24.1
  • php5-hash >= 5.2.14-0.7.24.1
  • php5-iconv >= 5.2.14-0.7.24.1
  • php5-json >= 5.2.14-0.7.24.1
  • php5-ldap >= 5.2.14-0.7.24.1
  • php5-mbstring >= 5.2.14-0.7.24.1
  • php5-mcrypt >= 5.2.14-0.7.24.1
  • php5-mysql >= 5.2.14-0.7.24.1
  • php5-odbc >= 5.2.14-0.7.24.1
  • php5-openssl >= 5.2.14-0.7.24.1
  • php5-pcntl >= 5.2.14-0.7.24.1
  • php5-pdo >= 5.2.14-0.7.24.1
  • php5-pear >= 5.2.14-0.7.24.1
  • php5-pgsql >= 5.2.14-0.7.24.1
  • php5-pspell >= 5.2.14-0.7.24.1
  • php5-shmop >= 5.2.14-0.7.24.1
  • php5-snmp >= 5.2.14-0.7.24.1
  • php5-soap >= 5.2.14-0.7.24.1
  • php5-suhosin >= 5.2.14-0.7.24.1
  • php5-sysvmsg >= 5.2.14-0.7.24.1
  • php5-sysvsem >= 5.2.14-0.7.24.1
  • php5-sysvshm >= 5.2.14-0.7.24.1
  • php5-tokenizer >= 5.2.14-0.7.24.1
  • php5-wddx >= 5.2.14-0.7.24.1
  • php5-xmlreader >= 5.2.14-0.7.24.1
  • php5-xmlrpc >= 5.2.14-0.7.24.1
  • php5-xmlwriter >= 5.2.14-0.7.24.1
  • php5-xsl >= 5.2.14-0.7.24.1
  • php5-zip >= 5.2.14-0.7.24.1
  • php5-zlib >= 5.2.14-0.7.24.1
Patchnames:
slessp1-apache2-mod_php5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES-10-SP3 php5 Released
SLES-10-SP4 php5 Released
SLES_LTSS-10-SP4 php5 Released
SUSE Linux Enterprise Server 11 SP1 php5 Released
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Released
SUSE Linux Enterprise Server for SAP Business All-in-One php5 Released
SUSE Linux Enterprise Software Development Kit 11 SP1 php5 Released