Upstream information

CVE-2011-1015 at MITRE

Description

The is_cgi method in CGIHTTPServer.py in the CGIHTTPServer module in Python 2.5, 2.6, and 3.0 allows remote attackers to read script source code via an HTTP GET request that lacks a / (slash) character at the beginning of the URI.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 674646 [RESOLVED / FIXED], 826682 [CLOSED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libpython2_6-1_0 >= 2.6.8-0.13.1
  • libpython2_6-1_0-32bit >= 2.6.8-0.13.1
  • libpython2_6-1_0-x86 >= 2.6.8-0.13.1
  • python >= 2.6.8-0.13.1
  • python-32bit >= 2.6.8-0.13.1
  • python-base >= 2.6.8-0.13.1
  • python-base-32bit >= 2.6.8-0.13.1
  • python-base-x86 >= 2.6.8-0.13.1
  • python-curses >= 2.6.8-0.13.1
  • python-demo >= 2.6.8-0.13.1
  • python-doc >= 2.6-8.13.2
  • python-doc-pdf >= 2.6-8.13.2
  • python-gdbm >= 2.6.8-0.13.1
  • python-idle >= 2.6.8-0.13.1
  • python-tk >= 2.6.8-0.13.1
  • python-x86 >= 2.6.8-0.13.1
  • python-xml >= 2.6.8-0.13.1
Patchnames:
slessp1-python-randomisation-update
SUSE Linux Enterprise Server 11 SP3
  • libpython2_6-1_0 >= 2.6.8-0.15.1
  • libpython2_6-1_0-32bit >= 2.6.8-0.15.1
  • libpython2_6-1_0-x86 >= 2.6.8-0.15.1
  • python-base >= 2.6.8-0.15.1
  • python-base-32bit >= 2.6.8-0.15.1
  • python-base-x86 >= 2.6.8-0.15.1
  • python-xml >= 2.6.8-0.15.1
SUSE Linux Enterprise Server 11 SP4
  • libpython2_6-1_0 >= 2.6.9-0.35.1
  • libpython2_6-1_0-32bit >= 2.6.9-0.35.1
  • libpython2_6-1_0-x86 >= 2.6.9-0.35.1
  • python-base >= 2.6.9-0.35.1
  • python-base-32bit >= 2.6.9-0.35.1
  • python-base-x86 >= 2.6.9-0.35.1
  • python-xml >= 2.6.9-0.35.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • python-devel >= 2.6.9-0.35.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 python Released
SLED-10-SP4 python Released
SLES-10-SP3 python Released
SLES-10-SP4 python Released
SLES_LTSS-10-SP4 python Released
SUSE Linux Enterprise Desktop 11 SP1 python Released
SUSE Linux Enterprise Server 11 SP1 python Released
SUSE Linux Enterprise Server 11 SP1 LTSS python Released
SUSE Linux Enterprise Server for SAP Business All-in-One python Released
SUSE Linux Enterprise Software Development Kit 11 SP1 python Released