Upstream information

CVE-2011-0188 at MITRE

Description

The VpMemAlloc function in bigdecimal.c in the BigDecimal class in Ruby 1.9.2-p136 and earlier, as used on Apple Mac OS X before 10.6.7 and other platforms, does not properly allocate memory, which allows context-dependent attackers to execute arbitrary code or cause a denial of service (application crash) via vectors involving creation of a large BigDecimal value within a 64-bit process, related to an "integer truncation issue."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 682287 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.28.1
  • ruby-doc-html >= 1.8.7.p72-5.28.1
  • ruby-tk >= 1.8.7.p72-5.28.1
Patchnames:
slessp1-ruby
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 ruby Unsupported
SLED-10-SP4 ruby Released
SLES for SAP Applications ruby Released
SUSE Lifecycle Management Server 1.3 ruby Released
SUSE Linux Enterprise Desktop 11 ruby Ignore
SUSE Linux Enterprise Desktop 11 SP1 ruby Released
SUSE Linux Enterprise Desktop 11 SP2 ruby Released
SUSE Linux Enterprise Desktop 11 SP3 ruby Released
SUSE Linux Enterprise Desktop 11 SP4 ruby Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ruby Released
SUSE Linux Enterprise Server 11 ruby Ignore
SUSE Linux Enterprise Server 11 SP1 ruby Released
SUSE Linux Enterprise Server 11 SP1 LTSS ruby Released
SUSE Linux Enterprise Server 11 SP2 ruby Released
SUSE Linux Enterprise Server 11 SP2 LTSS ruby Released
SUSE Linux Enterprise Server 11 SP2 for VMware ruby Released
SUSE Linux Enterprise Server 11 SP3 ruby Released
SUSE Linux Enterprise Server 11 SP3 LTSS ruby Released
SUSE Linux Enterprise Server 11 SP3 for VMware ruby Released
SUSE Linux Enterprise Server 11 SP4 ruby Released
SUSE Linux Enterprise Server 11 SP4 LTSS ruby Released
SUSE Linux Enterprise Server for SAP Business All-in-One ruby Released
SUSE Linux Enterprise Software Development Kit 11 ruby Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP1 ruby Released
SUSE Linux Enterprise Software Development Kit 11 SP2 ruby Released
SUSE Linux Enterprise Software Development Kit 11 SP3 ruby Released
SUSE Linux Enterprise Software Development Kit 11 SP4 ruby Released
SUSE Studio Extension for System z 1.2 ruby Released
SUSE Studio Onsite ruby Released
WebYaST for SLE-11 ruby Released