Upstream information

CVE-2011-0064 at MITRE

Description

The hb_buffer_ensure function in hb-buffer.c in HarfBuzz, as used in Pango 1.28.3, Firefox, and other products, does not verify that memory reallocations succeed, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) or possibly execute arbitrary code via crafted OpenType font data that triggers use of an incorrect index.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 666101 [RESOLVED / FIXED], 672502 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libpango-1_0-0 >= 1.40.14-3.3.1
  • libpango-1_0-0-32bit >= 1.40.14-3.3.1
  • pango-devel >= 1.40.14-3.3.1
  • typelib-1_0-Pango-1_0 >= 1.40.14-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libpango-1_0-0-1.40.14-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA libpango-1_0-0-32bit-1.40.14-3.3.1
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • pango-devel >= 1.26.2-1.3.1
  • pango-devel-32bit >= 1.26.2-1.3.1
  • pango-doc >= 1.26.2-1.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA pango-devel-1.26.2-1.3.1
SUSE Linux Enterprise Desktop 12 SP1
  • libpango-1_0-0 >= 1.36.3-4.14
  • libpango-1_0-0-32bit >= 1.36.3-4.14
  • pango-devel >= 1.36.3-4.14
  • pango-modules >= 1.36.3-4.14
  • pango-modules-32bit >= 1.36.3-4.14
  • typelib-1_0-Pango-1_0 >= 1.36.3-4.14
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libpango-1_0-0-1.36.3-4.14
SUSE Linux Enterprise Software Development Kit 12 SP1 GA pango-devel-1.36.3-4.14
SUSE Linux Enterprise Desktop 12 SP2
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP2 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Desktop 12 SP3
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP3 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Desktop 12 SP4
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP4 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Desktop 12
  • libpango-1_0-0 >= 1.36.3-4.14
  • libpango-1_0-0-32bit >= 1.36.3-4.14
  • pango-devel >= 1.36.3-4.14
  • pango-modules >= 1.36.3-4.14
  • pango-modules-32bit >= 1.36.3-4.14
  • typelib-1_0-Pango-1_0 >= 1.36.3-4.14
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libpango-1_0-0-1.36.3-4.14
SUSE Linux Enterprise Software Development Kit 12 GA pango-devel-1.36.3-4.14
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libpango-1_0-0 >= 1.40.14-1.41
  • libpango-1_0-0-32bit >= 1.40.14-1.41
  • pango-devel >= 1.40.14-1.41
  • typelib-1_0-Pango-1_0 >= 1.40.14-1.41
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpango-1_0-0-1.40.14-1.41
SUSE Linux Enterprise Module for Desktop Applications 15 GA libpango-1_0-0-32bit-1.40.14-1.41
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpango-1_0-0 >= 1.40.14-3.3.1
  • pango-devel >= 1.40.14-3.3.1
  • typelib-1_0-Pango-1_0 >= 1.40.14-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libpango-1_0-0-1.40.14-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • libpango-1_0-0 >= 1.40.14-1.41
  • pango-devel >= 1.40.14-1.41
  • typelib-1_0-Pango-1_0 >= 1.40.14-1.41
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpango-1_0-0-1.40.14-1.41
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libpango-1_0-0-32bit >= 1.40.14-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA libpango-1_0-0-32bit-1.40.14-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • libpango-1_0-0-32bit >= 1.40.14-1.41
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libpango-1_0-0-32bit-1.40.14-1.41
SUSE Linux Enterprise Server 11 SP1
  • pango >= 1.26.2-1.3.1
  • pango-32bit >= 1.26.2-1.3.1
  • pango-doc >= 1.26.2-1.3.1
  • pango-x86 >= 1.26.2-1.3.1
Patchnames:
slessp1-pango
SUSE Linux Enterprise Server 11 SP2
  • pango >= 1.26.2-1.3.1
  • pango-32bit >= 1.26.2-1.3.1
  • pango-doc >= 1.26.2-1.3.1
  • pango-x86 >= 1.26.2-1.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA pango-1.26.2-1.3.1
SUSE Linux Enterprise Server 11 SP3
  • pango >= 1.26.2-1.3.1
  • pango-32bit >= 1.26.2-1.3.1
  • pango-doc >= 1.26.2-1.3.1
  • pango-x86 >= 1.26.2-1.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA pango-1.26.2-1.3.1
SUSE Linux Enterprise Server 11 SP4
  • pango >= 1.26.2-1.3.1
  • pango-32bit >= 1.26.2-1.3.1
  • pango-devel >= 1.26.2-1.3.1
  • pango-devel-32bit >= 1.26.2-1.3.1
  • pango-doc >= 1.26.2-1.3.1
  • pango-x86 >= 1.26.2-1.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA pango-1.26.2-1.3.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA pango-devel-1.26.2-1.3.1
SUSE Linux Enterprise Server 12 SP1
  • libpango-1_0-0 >= 1.36.3-4.14
  • libpango-1_0-0-32bit >= 1.36.3-4.14
  • pango-devel >= 1.36.3-4.14
  • pango-modules >= 1.36.3-4.14
  • pango-modules-32bit >= 1.36.3-4.14
  • typelib-1_0-Pango-1_0 >= 1.36.3-4.14
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libpango-1_0-0-1.36.3-4.14
SUSE Linux Enterprise Software Development Kit 12 SP1 GA pango-devel-1.36.3-4.14
SUSE Linux Enterprise Server 12 SP2
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP2 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server 12 SP3
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP3 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server 12 SP4
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP4 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server 12 SP5
  • libpango-1_0-0 >= 1.40.1-9.5
  • libpango-1_0-0-32bit >= 1.40.1-9.5
  • pango-devel >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Software Development Kit 12 SP5 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server 12
  • libpango-1_0-0 >= 1.36.3-4.2
  • libpango-1_0-0-32bit >= 1.36.3-4.14
  • pango-devel >= 1.36.3-4.14
  • pango-modules >= 1.36.3-4.2
  • pango-modules-32bit >= 1.36.3-4.14
  • typelib-1_0-Pango-1_0 >= 1.36.3-4.2
Patchnames:
SUSE Linux Enterprise Server 12 GA libpango-1_0-0-1.36.3-4.14
SUSE Linux Enterprise Software Development Kit 12 GA pango-devel-1.36.3-4.14
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpango-1_0-0 >= 1.40.1-9.5
  • typelib-1_0-Pango-1_0 >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpango-1_0-0-1.40.1-9.5
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • pango-devel >= 1.36.3-4.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA pango-devel-1.36.3-4.14
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • pango-devel >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • pango-devel >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • pango-devel >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • pango-devel >= 1.40.1-9.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA pango-devel-1.40.1-9.5
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Software Development Kit 12
  • pango-devel >= 1.36.3-4.14
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA pango-devel-1.36.3-4.14
openSUSE Leap 15.0
  • libpango-1_0-0 >= 1.40.14-lp150.1.15
  • typelib-1_0-Pango-1_0 >= 1.40.14-lp150.1.15
Patchnames:
openSUSE Leap 15.0 GA libpango-1_0-0-1.40.14-lp150.1.15
openSUSE Tumbleweed
  • libpango-1_0-0 >= 1.40.3-1.1
  • libpango-1_0-0-32bit >= 1.40.3-1.1
  • pango-devel >= 1.40.3-1.1
  • pango-devel-32bit >= 1.40.3-1.1
  • pango-tools >= 1.40.3-1.1
  • typelib-1_0-Pango-1_0 >= 1.40.3-1.1
Patchnames:
openSUSE Tumbleweed GA libpango-1_0-0-1.40.3-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications pango Released
SUSE Linux Enterprise Desktop 11 SP1 pango Released
SUSE Linux Enterprise Desktop 11 SP2 pango Released
SUSE Linux Enterprise Desktop 11 SP3 pango Released
SUSE Linux Enterprise Desktop 11 SP4 pango Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search pango Released
SUSE Linux Enterprise Server 11 SP1 pango Released
SUSE Linux Enterprise Server 11 SP1 LTSS pango Released
SUSE Linux Enterprise Server 11 SP2 pango Released
SUSE Linux Enterprise Server 11 SP2 LTSS pango Released
SUSE Linux Enterprise Server 11 SP3 pango Released
SUSE Linux Enterprise Server 11 SP3 LTSS pango Released
SUSE Linux Enterprise Server 11 SP3-LTSS pango Affected
SUSE Linux Enterprise Server 11 SP4 pango Released
SUSE Linux Enterprise Server 11 SP4 LTSS firefox-pango Affected
SUSE Linux Enterprise Server 11 SP4 LTSS pango Released
SUSE Linux Enterprise Server 11 SP4-LTSS firefox-pango Affected
SUSE Linux Enterprise Server 11 SP4-LTSS pango Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 pango Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 pango Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 pango Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 pango Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 pango Released
SUSE Linux Enterprise Software Development Kit 11 SP1 pango Released
SUSE Linux Enterprise Software Development Kit 11 SP2 pango Released
SUSE Linux Enterprise Software Development Kit 11 SP3 pango Released
SUSE Linux Enterprise Software Development Kit 11 SP4 pango Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 04:16:45 2013
CVE page last modified: Sat Dec 3 00:42:05 2022