Upstream information

CVE-2010-4542 at MITRE

Description

Stack-based buffer overflow in the gfig_read_parameter_gimp_rgb function in plug-ins/gfig/gfig-style.c in the GFIG plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long Foreground field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 662043 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gimp >= 2.8.18-4.7
  • gimp-lang >= 2.8.18-4.7
  • gimp-plugins-python >= 2.8.18-4.7
  • libgimp-2_0-0 >= 2.8.18-4.7
  • libgimpui-2_0-0 >= 2.8.18-4.7
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP3
  • gimp >= 2.8.18-8.1
  • gimp-lang >= 2.8.18-8.1
  • gimp-plugins-python >= 2.8.18-8.1
  • libgimp-2_0-0 >= 2.8.18-8.1
  • libgimpui-2_0-0 >= 2.8.18-8.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • gimp >= 2.8.18-9.3.26
  • gimp-lang >= 2.8.18-9.3.26
  • gimp-plugins-python >= 2.8.18-9.3.26
  • libgimp-2_0-0 >= 2.8.18-9.3.26
  • libgimpui-2_0-0 >= 2.8.18-9.3.26
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
  • gimp >= 2.8.10-1.164
  • gimp-lang >= 2.8.10-1.164
  • gimp-plugins-python >= 2.8.10-1.164
  • libgimp-2_0-0 >= 2.8.10-1.164
  • libgimpui-2_0-0 >= 2.8.10-1.164
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gimp >= 2.6.2-3.34.45.1
  • gimp-devel >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gimp-devel >= 2.8.18-4.7
  • libgimp-2_0-0 >= 2.8.18-4.7
  • libgimpui-2_0-0 >= 2.8.18-4.7
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gimp-devel >= 2.8.18-8.1
  • libgimp-2_0-0 >= 2.8.18-8.1
  • libgimpui-2_0-0 >= 2.8.18-8.1
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • gimp-devel >= 2.8.18-9.3.26
  • libgimp-2_0-0 >= 2.8.18-9.3.26
  • libgimpui-2_0-0 >= 2.8.18-9.3.26
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gimp-devel >= 2.8.10-1.164
  • libgimp-2_0-0 >= 2.8.10-1.164
  • libgimpui-2_0-0 >= 2.8.10-1.164
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Workstation Extension 15 SP1
  • gimp >= 2.8.22-3.42
  • gimp-devel >= 2.8.22-3.42
  • gimp-lang >= 2.8.22-3.42
  • gimp-plugins-python >= 2.8.22-3.42
  • libgimp-2_0-0 >= 2.8.22-3.42
  • libgimpui-2_0-0 >= 2.8.22-3.42
openSUSE Leap 15.0
  • gimp >= 2.8.22-lp150.3.8
  • gimp-lang >= 2.8.22-lp150.3.8
  • gimp-plugins-python >= 2.8.22-lp150.3.8
  • libgimp-2_0-0 >= 2.8.22-lp150.3.8
  • libgimpui-2_0-0 >= 2.8.22-lp150.3.8
Patchnames:
openSUSE Leap 15.0 GA gimp-2.8.22-lp150.3.8
openSUSE Tumbleweed
  • gimp >= 2.8.18-1.4
  • gimp-devel >= 2.8.18-1.4
  • gimp-help-browser >= 2.8.18-1.4
  • gimp-lang >= 2.8.18-1.4
  • gimp-plugin-aa >= 2.8.18-1.4
  • gimp-plugins-python >= 2.8.18-1.4
  • libgimp-2_0-0 >= 2.8.18-1.4
  • libgimp-2_0-0-32bit >= 2.8.18-1.4
  • libgimpui-2_0-0 >= 2.8.18-1.4
  • libgimpui-2_0-0-32bit >= 2.8.18-1.4
Patchnames:
openSUSE Tumbleweed GA gimp-2.8.18-1.4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 gimp Released
SUSE Linux Enterprise Desktop 11 SP1 gimp Released
SUSE Linux Enterprise Software Development Kit 11 SP1 gimp Released