Upstream information

CVE-2010-4531 at MITRE

Description

Stack-based buffer overflow in the ATRDecodeAtr function in the Answer-to-Reset (ATR) Handler (atrhandler.c) for pcscd in PCSC-Lite 1.5.3, and possibly other 1.5.x and 1.6.x versions, allows physically proximate attackers to cause a denial of service (crash) and possibly execute arbitrary code via a smart card with an ATR message containing a long attribute value.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 661000 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libpcsclite1 >= 1.8.10-6.1
  • libpcsclite1-32bit >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
SUSE Linux Enterprise Desktop 12 SP4
  • libpcsclite1 >= 1.8.10-7.3.1
  • libpcsclite1-32bit >= 1.8.10-7.3.1
  • pcsc-lite >= 1.8.10-7.3.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
  • libpcsclite1 >= 1.8.10-3.7
  • libpcsclite1-32bit >= 1.8.10-3.7
  • pcsc-lite >= 1.8.10-3.7
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libpcsclite1 >= 1.8.10-7.6.3
  • pcsc-lite >= 1.8.10-7.6.3
SUSE Linux Enterprise Module for Basesystem 15
  • libpcsclite1 >= 1.8.23-2.27
  • libpcscspy0 >= 1.8.23-2.27
  • pcsc-lite >= 1.8.23-2.27
  • pcsc-lite-devel >= 1.8.23-2.27
SUSE Linux Enterprise Server 11 SP1
  • pcsc-ccid >= 1.3.8-3.15.1
  • pcsc-lite >= 1.4.102-1.37.3
  • pcsc-lite-32bit >= 1.4.102-1.37.3
  • pcsc-lite-x86 >= 1.4.102-1.37.3
Patchnames:
slessp1-pcsc-ccid
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • pcsc-lite >= 1.4.102-1.37.3
  • pcsc-lite-32bit >= 1.4.102-1.37.3
  • pcsc-lite-x86 >= 1.4.102-1.37.3
SUSE Linux Enterprise Server 12 SP3
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
SUSE Linux Enterprise Server 12 SP4
  • libpcsclite1 >= 1.8.10-7.3.1
  • pcsc-lite >= 1.8.10-7.3.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
  • libpcsclite1 >= 1.8.10-3.7
  • pcsc-lite >= 1.8.10-3.7
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpcsclite1 >= 1.8.10-3.4
  • pcsc-lite >= 1.8.10-3.4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • pcsc-lite-devel >= 1.4.102-1.37.3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpcscspy0 >= 1.8.10-6.1
  • pcsc-lite-devel >= 1.8.10-6.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpcscspy0 >= 1.8.10-7.3.1
  • pcsc-lite-devel >= 1.8.10-7.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpcscspy0 >= 1.8.10-7.6.3
  • pcsc-lite-devel >= 1.8.10-7.6.3
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpcscspy0 >= 1.8.10-3.7
  • pcsc-lite-devel >= 1.8.10-3.7
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpcsclite1-32bit >= 1.8.10-6.1
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libpcsclite1-32bit >= 1.8.10-7.3.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libpcsclite1-32bit >= 1.8.10-7.6.3
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpcsclite1-32bit >= 1.8.10-3.7
openSUSE Leap 15.0
  • libpcsclite1 >= 1.8.23-lp150.2.1
  • pcsc-lite >= 1.8.23-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libpcsclite1-1.8.23-lp150.2.1
openSUSE Tumbleweed
  • libpcsclite1 >= 1.8.18-1.1
  • libpcsclite1-32bit >= 1.8.18-1.1
  • libpcscspy0 >= 1.8.18-1.1
  • libpcscspy0-32bit >= 1.8.18-1.1
  • pcsc-lite >= 1.8.18-1.1
  • pcsc-lite-devel >= 1.8.18-1.1
Patchnames:
openSUSE Tumbleweed GA libpcsclite1-1.8.18-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 pcsc-lite Released
SLED-10-SP4 pcsc-lite Released
SLES-10-SP3 pcsc-lite Released
SLES-10-SP4 pcsc-lite Released
SLES_LTSS-10-SP4 pcsc-lite Released
SUSE Linux Enterprise Desktop 11 SP1 pcsc-lite Released
SUSE Linux Enterprise High Performance Computing 15 LTSS pcsc-ccid Already fixed
SUSE Linux Enterprise Server 11 SP1 pcsc-lite Released
SUSE Linux Enterprise Server 11 SP1 LTSS pcsc-lite Released
SUSE Linux Enterprise Server 15 ESPOS pcsc-ccid Already fixed
SUSE Linux Enterprise Server 15 LTSS pcsc-ccid Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 pcsc-ccid Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 pcsc-lite Released
SUSE Linux Enterprise Software Development Kit 11 SP1 pcsc-lite Released