Upstream information

CVE-2010-4180 at MITRE

Description

OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 657663 [RESOLVED / FIXED], 674017 [RESOLVED / DUPLICATE], 711693 [RESOLVED / INVALID], 724729 [RESOLVED / INVALID], 799454 [VERIFIED / WONTFIX]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libopenssl0_9_8 >= 0.9.8j-81.1
  • libopenssl0_9_8-32bit >= 0.9.8j-81.1
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl0_9_8 >= 0.9.8j-102.1
  • libopenssl0_9_8-32bit >= 0.9.8j-102.1
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl0_9_8 >= 0.9.8j-105.1
  • libopenssl0_9_8-32bit >= 0.9.8j-105.1
SUSE Linux Enterprise Desktop 12 SP4
  • libopenssl0_9_8 >= 0.9.8j-106.6.1
  • libopenssl0_9_8-32bit >= 0.9.8j-106.6.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Module for Legacy 12
  • libopenssl0_9_8 >= 0.9.8j-59.11
  • libopenssl0_9_8-32bit >= 0.9.8j-59.11
SUSE Linux Enterprise Server 11 SP1
  • libopenssl-devel >= 0.9.8j-0.66.1
  • libopenssl0_9_8 >= 0.9.8h-30.30.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.66.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.66.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.66.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.44.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.44.1
  • openssl >= 0.9.8h-30.30.1
  • openssl-doc >= 0.9.8h-30.30.1
Patchnames:
slessp1-libopenssl-devel
SUSE Linux Enterprise Server 11 SP2
  • curl >= 7.19.7-1.18.1
  • libcurl4 >= 7.19.7-1.18.1
  • libcurl4-32bit >= 7.19.7-1.18.1
  • libcurl4-x86 >= 7.19.7-1.18.1
  • libopenssl0_9_8 >= 0.9.8j-0.26.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.26.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.26.1
  • openssl >= 0.9.8j-0.26.1
  • openssl-doc >= 0.9.8j-0.26.1
SUSE Linux Enterprise Server 11 SP3
  • curl >= 7.19.7-1.26.8
  • libcurl4 >= 7.19.7-1.26.8
  • libcurl4-32bit >= 7.19.7-1.26.8
  • libcurl4-x86 >= 7.19.7-1.26.8
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
SUSE Linux Enterprise Server 11 SP4
  • curl >= 7.19.7-1.42.1
  • libcurl4 >= 7.19.7-1.42.1
  • libcurl4-32bit >= 7.19.7-1.42.1
  • libcurl4-x86 >= 7.19.7-1.42.1
  • libopenssl0_9_8 >= 0.9.8j-0.70.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.70.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.70.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.70.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.70.1
  • openssl >= 0.9.8j-0.70.1
  • openssl-doc >= 0.9.8j-0.70.1
SUSE Linux Enterprise Server 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.55.1
  • libcurl4-openssl1 >= 7.19.7-0.38.1
  • libcurl4-openssl1-32bit >= 7.19.7-0.38.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libcurl-devel >= 7.19.7-1.42.1
  • libopenssl-devel >= 0.9.8j-0.70.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 compat-openssl097g Released
SLED-10-SP3 curl Released
SLED-10-SP3 openssl Released
SLED-10-SP4 compat-openssl097g Released
SLED-10-SP4 curl Released
SLED-10-SP4 openssl Released
SLES for SAP Applications openssl Affected
SLES-10-SP3 compat-openssl097g Released
SLES-10-SP3 curl Released
SLES-10-SP3 openssl Released
SLES-10-SP4 compat-openssl097g Released
SLES-10-SP4 curl Released
SLES-10-SP4 openssl Released
SLES_LTSS-10-SP4 compat-openssl097g Released
SLES_LTSS-10-SP4 curl Released
SLES_LTSS-10-SP4 openssl Released
SUSE Linux Enterprise Desktop 11 SP1 compat-openssl097g Released
SUSE Linux Enterprise Desktop 11 SP1 curl Released
SUSE Linux Enterprise Desktop 11 SP1 openssl Affected
SUSE Linux Enterprise Desktop 11 SP2 curl Released
SUSE Linux Enterprise Desktop 11 SP2 openssl Affected
SUSE Linux Enterprise Desktop 11 SP3 curl Released
SUSE Linux Enterprise Desktop 11 SP3 openssl Affected
SUSE Linux Enterprise Desktop 11 SP4 openssl Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search openssl Affected
SUSE Linux Enterprise Module for Legacy 12 compat-openssl098 Already fixed
SUSE Linux Enterprise Server 11 SP1 curl Released
SUSE Linux Enterprise Server 11 SP1 openssl Affected
SUSE Linux Enterprise Server 11 SP1 LTSS curl Released
SUSE Linux Enterprise Server 11 SP1 LTSS openssl Affected
SUSE Linux Enterprise Server 11 SP2 curl Released
SUSE Linux Enterprise Server 11 SP2 openssl Affected
SUSE Linux Enterprise Server 11 SP2 LTSS curl Released
SUSE Linux Enterprise Server 11 SP2 LTSS openssl Affected
SUSE Linux Enterprise Server 11 SP2 for VMware curl Released
SUSE Linux Enterprise Server 11 SP2 for VMware openssl Affected
SUSE Linux Enterprise Server 11 SP3 curl Released
SUSE Linux Enterprise Server 11 SP3 openssl Affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Affected
SUSE Linux Enterprise Server 11 SP3 for VMware curl Released
SUSE Linux Enterprise Server 11 SP3 for VMware openssl Affected
SUSE Linux Enterprise Server 11 SP4 openssl Affected
SUSE Linux Enterprise Server 11 SP4 LTSS openssl Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 compat-openssl098 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 compat-openssl098 Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One compat-openssl097g Released
SUSE Linux Enterprise Server for SAP Business All-in-One curl Released
SUSE Linux Enterprise Server for SAP Business All-in-One openssl Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 curl Released
SUSE Linux Enterprise Software Development Kit 11 SP1 openssl Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 curl Released
SUSE Linux Enterprise Software Development Kit 11 SP2 openssl Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 curl Released
SUSE Linux Enterprise Software Development Kit 11 SP3 openssl Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 openssl Affected
SUSE Studio Onsite curl Unsupported
SUSE Studio Onsite openssl Affected