CVE-2010-4172

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2010-4172 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in the Manager application in Apache Tomcat 6.0.12 through 6.0.29 and 7.0.0 through 7.0.4 allow remote attackers to inject arbitrary web script or HTML via the (1) orderBy or (2) sort parameter to sessionsList.jsp, or unspecified input to (3) sessionDetail.jsp or (4) java/org/apache/catalina/manager/JspHelper.java, related to use of untrusted web applications.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.30
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 655440 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP1
  • tomcat6 >= 6.0.18-20.18.1
  • tomcat6-admin-webapps >= 6.0.18-20.18.1
  • tomcat6-docs-webapp >= 6.0.18-20.18.1
  • tomcat6-javadoc >= 6.0.18-20.18.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.18.1
  • tomcat6-lib >= 6.0.18-20.18.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.18.1
  • tomcat6-webapps >= 6.0.18-20.18.1
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86-64
SAT Patch Nr: 3858
openSUSE 11.2
  • tomcat6 >= 6.0.20-24.27.2
  • tomcat6-admin-webapps >= 6.0.20-24.27.2
  • tomcat6-docs-webapp >= 6.0.20-24.27.2
  • tomcat6-javadoc >= 6.0.20-24.27.2
  • tomcat6-jsp-2_1-api >= 6.0.20-24.27.2
  • tomcat6-lib >= 6.0.20-24.27.2
  • tomcat6-servlet-2_5-api >= 6.0.20-24.27.2
  • tomcat6-webapps >= 6.0.20-24.27.2
openSUSE 11.3
  • tomcat6 >= 6.0.24-5.8.2
  • tomcat6-admin-webapps >= 6.0.24-5.8.2
  • tomcat6-docs-webapp >= 6.0.24-5.8.2
  • tomcat6-el-1_0-api >= 6.0.24-5.8.2
  • tomcat6-javadoc >= 6.0.24-5.8.2
  • tomcat6-jsp-2_1-api >= 6.0.24-5.8.2
  • tomcat6-lib >= 6.0.24-5.8.2
  • tomcat6-servlet-2_5-api >= 6.0.24-5.8.2
  • tomcat6-webapps >= 6.0.24-5.8.2
openSUSE 11.2
  • tomcat6 >= 6.0.20-24.31.1
  • tomcat6-admin-webapps >= 6.0.20-24.31.1
  • tomcat6-docs-webapp >= 6.0.20-24.31.1
  • tomcat6-javadoc >= 6.0.20-24.31.1
  • tomcat6-jsp-2_1-api >= 6.0.20-24.31.1
  • tomcat6-lib >= 6.0.20-24.31.1
  • tomcat6-servlet-2_5-api >= 6.0.20-24.31.1
  • tomcat6-webapps >= 6.0.20-24.31.1