Upstream information

CVE-2010-4015 at MITRE

Description

Buffer overflow in the gettoken function in contrib/intarray/_int_bool.c in the intarray array module in PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before 8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via integers with a large number of digits to unspecified functions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 660478 [RESOLVED / FIXED], 684292 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql-devel >= 8.3.23-0.4.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql-devel-8.3.23-0.4.1
SUSE Linux Enterprise Server 11 SP1
  • postgresql >= 8.3.14-0.2.1
  • postgresql-contrib >= 8.3.14-0.2.1
  • postgresql-docs >= 8.3.14-0.2.1
  • postgresql-init >= 9.1-0.6.10.1
  • postgresql-libs >= 8.3.14-0.2.1
  • postgresql-libs-32bit >= 8.3.18-0.3.1
  • postgresql-libs-x86 >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.14-0.2.1
Patchnames:
slessp1-postgresql
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.14-0.2.1
  • postgresql-contrib >= 8.3.14-0.2.1
  • postgresql-docs >= 8.3.14-0.2.1
  • postgresql-libs >= 8.3.14-0.2.1
  • postgresql-libs-32bit >= 8.3.14-0.2.1
  • postgresql-libs-x86 >= 8.3.14-0.2.1
  • postgresql-server >= 8.3.14-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA postgresql-8.3.14-0.2.1
SUSE Linux Enterprise Server 11 SP3
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA postgresql-8.3.23-0.4.1
SUSE Linux Enterprise Server 11 SP4
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-devel >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA postgresql-8.3.23-0.4.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql-devel-8.3.23-0.4.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 postgresql Released
SUSE Linux Enterprise Server 11 SP1 postgresql Released
SUSE Linux Enterprise Server 11 SP1 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP3 postgresql Affected
SUSE Linux Enterprise Server 11 SP3-LTSS postgresql Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 postgresql Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 07:47:32 2013
CVE page last modified: Tue Nov 29 12:01:17 2022