Upstream information

CVE-2010-3856 at MITRE

Description

ld.so in the GNU C Library (aka glibc or libc6) before 2.11.3, and 2.12.x before 2.12.2, does not properly restrict use of the LD_AUDIT environment variable to reference dynamic shared objects (DSOs) as audit objects, which allows local users to gain privileges by leveraging an unsafe DSO located in a trusted library directory, as demonstrated by libpcprofile.so.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 646960 [RESOLVED / FIXED], 648020 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • glibc >= 2.11.1-0.20.1
  • glibc-32bit >= 2.11.1-0.58.1
  • glibc-devel >= 2.11.1-0.20.1
  • glibc-devel-32bit >= 2.11.1-0.58.1
  • glibc-html >= 2.11.1-0.20.1
  • glibc-i18ndata >= 2.11.1-0.20.1
  • glibc-info >= 2.11.1-0.20.1
  • glibc-locale >= 2.11.1-0.20.1
  • glibc-locale-32bit >= 2.11.1-0.58.1
  • glibc-locale-x86 >= 2.11.1-0.38.1
  • glibc-profile >= 2.11.1-0.20.1
  • glibc-profile-32bit >= 2.11.1-0.58.1
  • glibc-profile-x86 >= 2.11.1-0.38.1
  • glibc-x86 >= 2.11.1-0.38.1
  • libxcrypt >= 3.0.3-0.4.1
  • libxcrypt-32bit >= 3.0.3-0.4.1
  • nscd >= 2.11.1-0.20.1
  • pam-modules >= 11-1.18.1
  • pam-modules-32bit >= 11-1.18.1
  • pwdutils >= 3.2.8-0.4.1
  • pwdutils-plugin-audit >= 3.2.8-0.4.1
Patchnames:
slessp1-glibc
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • glibc >= 2.9-13.11.1
  • glibc-32bit >= 2.9-13.11.1
  • glibc-devel >= 2.9-13.11.1
  • glibc-devel-32bit >= 2.9-13.11.1
  • glibc-html >= 2.9-13.11.1
  • glibc-i18ndata >= 2.9-13.11.1
  • glibc-info >= 2.9-13.11.1
  • glibc-locale >= 2.9-13.11.1
  • glibc-locale-32bit >= 2.9-13.11.1
  • glibc-locale-x86 >= 2.9-13.11.1
  • glibc-profile >= 2.9-13.11.1
  • glibc-profile-32bit >= 2.9-13.11.1
  • glibc-profile-x86 >= 2.9-13.11.1
  • glibc-x86 >= 2.9-13.11.1
  • nscd >= 2.9-13.11.1
Patchnames:
slessp0-glibc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 glibc Released
SUSE Linux Enterprise Desktop 11 SP1 glibc Released
SUSE Linux Enterprise Server 11 glibc Released
SUSE Linux Enterprise Server 11 SP1 glibc Released
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Released
SUSE Linux Enterprise Server for SAP Applications 11 glibc Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 glibc Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 glibc Released
SUSE Linux Enterprise Software Development Kit 11 glibc Released
SUSE Linux Enterprise Software Development Kit 11 SP1 glibc Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 07:37:29 2013
CVE page last modified: Tue Jan 17 14:03:20 2023