Upstream information

CVE-2010-3835 at MITRE

Description

MySQL 5.1 before 5.1.51 and 5.5 before 5.5.6 allows remote authenticated users to cause a denial of service (mysqld server crash) by performing a user-variable assignment in a logical expression that is calculated and stored in a temporary table for GROUP BY, then causing the expression value to be used after the table is created, which causes the expression to be re-evaluated instead of accessing its value from the table.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 644864 [RESOLVED / FIXED], 694232 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysqlclient-devel-5.0.96-0.6.1
SUSE Linux Enterprise Server 11 SP1
  • libmysqlclient15 >= 5.0.94-0.2.2.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.4.1
  • libmysqlclient_r15 >= 5.0.94-0.2.2.1
  • mysql >= 5.0.94-0.2.2.1
  • mysql-Max >= 5.0.94-0.2.2.1
  • mysql-client >= 5.0.94-0.2.2.1
  • mysql-tools >= 5.0.96-0.6.1
Patchnames:
slessp1-libmysqlclient-devel
SUSE Linux Enterprise Server 11 SP2
  • libmysqlclient15 >= 5.0.94-0.2.4.1
  • libmysqlclient15-32bit >= 5.0.94-0.2.4.1
  • libmysqlclient15-x86 >= 5.0.94-0.2.4.1
  • libmysqlclient_r15 >= 5.0.94-0.2.4.1
  • mysql >= 5.0.94-0.2.4.1
  • mysql-Max >= 5.0.94-0.2.4.1
  • mysql-client >= 5.0.94-0.2.4.1
  • mysql-tools >= 5.0.94-0.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libmysqlclient15-32bit-5.0.94-0.2.4.1
SUSE Linux Enterprise Server 11 SP3
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • mysql >= 5.5.31-0.7.10
  • mysql-client >= 5.5.31-0.7.10
  • mysql-tools >= 5.5.31-0.7.10
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libmysqlclient15-32bit-5.0.96-0.6.1
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient15 >= 5.0.96-0.6.20
  • libmysqlclient15-32bit >= 5.0.96-0.6.20
  • libmysqlclient15-x86 >= 5.0.96-0.6.20
  • libmysqlclient_r15 >= 5.0.96-0.6.20
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libmysql55client18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Server 11 SP4 GA libmysqlclient15-32bit-5.0.96-0.6.20
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit-5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysqlclient-devel-5.0.96-0.6.1