Upstream information

CVE-2010-3450 at MITRE

Description

Multiple directory traversal vulnerabilities in OpenOffice.org (OOo) 2.x and 3.x before 3.3 allow remote attackers to overwrite arbitrary files via a .. (dot dot) in an entry in (1) an XSLT JAR filter description file, (2) an Extension (aka OXT) file, or unspecified other (3) JAR or (4) ZIP files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 667421 [RESOLVED / FIXED], 683605 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libreoffice >= 4.0.3.3.26-0.10.2
  • libreoffice-base >= 4.0.3.3.26-0.10.2
  • libreoffice-base-drivers-postgresql >= 4.0.3.3.26-0.10.2
  • libreoffice-base-extensions >= 4.0.3.3.26-0.10.2
  • libreoffice-calc >= 4.0.3.3.26-0.10.2
  • libreoffice-calc-extensions >= 4.0.3.3.26-0.10.2
  • libreoffice-draw >= 4.0.3.3.26-0.10.2
  • libreoffice-draw-extensions >= 4.0.3.3.26-0.10.2
  • libreoffice-filters-optional >= 4.0.3.3.26-0.10.2
  • libreoffice-gnome >= 4.0.3.3.26-0.10.2
  • libreoffice-impress >= 4.0.3.3.26-0.10.2
  • libreoffice-impress-extensions >= 4.0.3.3.26-0.10.2
  • libreoffice-kde >= 4.0.3.3.26-0.10.2
  • libreoffice-kde4 >= 4.0.3.3.26-0.10.2
  • libreoffice-l10n-prebuilt >= 4.0.3.3.26-0.10.2
  • libreoffice-mailmerge >= 4.0.3.3.26-0.10.2
  • libreoffice-math >= 4.0.3.3.26-0.10.2
  • libreoffice-mono >= 4.0.3.3.26-0.10.2
  • libreoffice-officebean >= 4.0.3.3.26-0.10.2
  • libreoffice-pyuno >= 4.0.3.3.26-0.10.2
  • libreoffice-sdk >= 4.0.3.3.26-0.10.2
  • libreoffice-testtool >= 3.4.5.5-0.3.1
  • libreoffice-writer >= 4.0.3.3.26-0.10.2
  • libreoffice-writer-extensions >= 4.0.3.3.26-0.10.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libreoffice-4.0.3.3.26-0.10.2
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libreoffice-testtool-3.4.5.5-0.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 libreoffice-languagetool Released
SUSE Linux Enterprise Desktop 11 SP2 libreoffice-languagetool Released
SUSE Linux Enterprise Desktop 11 SP3 libreoffice-languagetool Released
SUSE Linux Enterprise Desktop 11 SP4 libreoffice-languagetool Released
SUSE Linux Enterprise Server 11 SP1 libreoffice-languagetool Released
SUSE Linux Enterprise Server 11 SP2 libreoffice-languagetool Released
SUSE Linux Enterprise Server 11 SP3 libreoffice-languagetool Released
SUSE Linux Enterprise Server 11 SP4 libreoffice-languagetool Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 libreoffice-languagetool Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 libreoffice-languagetool Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libreoffice-languagetool Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libreoffice-languagetool Released
SUSE Linux Enterprise Software Development Kit 11 SP1 libreoffice-languagetool Released
SUSE Linux Enterprise Software Development Kit 11 SP2 libreoffice-languagetool Released
SUSE Linux Enterprise Software Development Kit 11 SP3 libreoffice-languagetool Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libreoffice-languagetool Released