Upstream information

CVE-2010-3192 at MITRE

Description

Certain run-time memory protection mechanisms in the GNU C Library (aka glibc or libc6) print argv[0] and backtrace information, which might allow context-dependent attackers to obtain sensitive information from process memory by executing an incorrect program, as demonstrated by a setuid program that contains a stack-based buffer overflow error, related to the __fortify_fail function in debug/fortify_fail.c, and the __stack_chk_fail (aka stack protection) and __chk_fail (aka FORTIFY_SOURCE) implementations.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 636113 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • glibc >= 2.26-13.19.1
  • glibc-32bit >= 2.26-13.19.1
  • glibc-devel >= 2.26-13.19.1
  • glibc-extra >= 2.26-13.19.1
  • glibc-i18ndata >= 2.26-13.19.1
  • glibc-info >= 2.26-13.19.1
  • glibc-locale >= 2.26-13.19.1
  • glibc-locale-32bit >= 2.26-8.21
  • glibc-locale-base >= 2.26-13.19.1
  • glibc-profile >= 2.26-13.19.1
  • nscd >= 2.26-13.19.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • glibc >= 2.26-13.48.1
  • glibc-32bit >= 2.26-13.48.1
  • glibc-devel >= 2.26-13.48.1
  • glibc-extra >= 2.26-13.48.1
  • glibc-i18ndata >= 2.26-13.48.1
  • glibc-info >= 2.26-13.48.1
  • glibc-locale >= 2.26-13.48.1
  • glibc-locale-32bit >= 2.26-8.21
  • glibc-locale-base >= 2.26-13.48.1
  • glibc-locale-base-32bit >= 2.26-13.48.1
  • glibc-profile >= 2.26-13.48.1
  • nscd >= 2.26-13.48.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • glibc >= 2.31-7.30
  • glibc-32bit >= 2.31-7.20
  • glibc-devel >= 2.31-7.30
  • glibc-extra >= 2.31-7.30
  • glibc-i18ndata >= 2.31-7.30
  • glibc-info >= 2.31-7.30
  • glibc-lang >= 2.31-7.30
  • glibc-locale >= 2.31-7.30
  • glibc-locale-32bit >= 2.26-13.8.1
  • glibc-locale-base >= 2.31-7.30
  • glibc-locale-base-32bit >= 2.31-7.20
  • glibc-profile >= 2.31-7.30
  • nscd >= 2.31-7.30
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-11.8
  • glibc-32bit >= 2.26-11.8
  • glibc-devel >= 2.26-11.8
  • glibc-extra >= 2.26-11.8
  • glibc-i18ndata >= 2.26-11.8
  • glibc-info >= 2.26-11.8
  • glibc-locale >= 2.26-11.8
  • glibc-locale-32bit >= 2.26-11.8
  • glibc-profile >= 2.26-11.8
  • nscd >= 2.26-11.8
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • glibc-devel-32bit >= 2.26-8.21
  • glibc-devel-static >= 2.26-13.19.1
  • glibc-utils >= 2.26-13.19.1
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • glibc-devel-32bit >= 2.26-13.48.1
  • glibc-devel-static >= 2.26-13.48.1
  • glibc-utils >= 2.26-13.48.1
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • glibc-devel-32bit >= 2.31-7.20
  • glibc-devel-static >= 2.31-7.30
  • glibc-utils >= 2.31-7.1
SUSE Linux Enterprise Module for Development Tools 15
  • glibc-devel-32bit >= 2.26-11.8
  • glibc-devel-static >= 2.26-11.8
  • glibc-utils >= 2.26-11.8
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.10.13
  • glibc-32bit >= 2.26-lp150.10.13
  • glibc-extra >= 2.26-lp150.10.13
  • glibc-locale >= 2.26-lp150.10.13
  • glibc-locale-32bit >= 2.26-lp150.10.13
  • nscd >= 2.26-lp150.10.13
Patchnames:
openSUSE Leap 15.0 GA glibc-2.26-lp150.10.13
openSUSE Tumbleweed
  • glibc >= 2.34-1.2
  • glibc-devel >= 2.34-1.2
  • glibc-devel-static >= 2.34-1.2
  • glibc-extra >= 2.34-1.2
  • glibc-html >= 2.34-1.2
  • glibc-i18ndata >= 2.34-1.2
  • glibc-info >= 2.34-1.2
  • glibc-lang >= 2.34-1.2
  • glibc-locale >= 2.34-1.2
  • glibc-locale-base >= 2.34-1.2
  • glibc-profile >= 2.34-1.2
  • nscd >= 2.34-1.2
Patchnames:
openSUSE Tumbleweed GA glibc-2.34-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 glibc Already fixed
SUSE Enterprise Storage 6 glibc Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS glibc Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS glibc Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 glibc Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 glibc Already fixed
SUSE Linux Enterprise Server 15 ESPOS glibc Already fixed
SUSE Linux Enterprise Server 15 LTSS glibc Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS glibc Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glibc Already fixed
SUSE Manager Proxy 4.0 glibc Already fixed
SUSE Manager Retail Branch Server 4.0 glibc Already fixed
SUSE Manager Server 4.0 glibc Already fixed