Upstream information

CVE-2010-2496 at MITRE

Description

stonith-ng in pacemaker and cluster-glue passed passwords as commandline parameters, making it possible for local attackers to gain access to passwords of the HA stack and potentially influence its operations. This is fixed in cluster-glue 1.0.6 and newer, and pacemaker 1.1.3 and newer.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 620781 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP2
  • libpacemaker3 >= 1.1.15-19.15
  • pacemaker >= 1.1.15-19.15
  • pacemaker-cli >= 1.1.15-19.15
  • pacemaker-cts >= 1.1.15-19.15
  • pacemaker-remote >= 1.1.15-19.15
SUSE Linux Enterprise High Availability 12 SP3
  • libpacemaker3 >= 1.1.16-4.8
  • pacemaker >= 1.1.16-4.8
  • pacemaker-cli >= 1.1.16-4.8
  • pacemaker-cts >= 1.1.16-4.8
  • pacemaker-remote >= 1.1.16-4.8
SUSE Linux Enterprise High Availability 12 SP4
  • libpacemaker3 >= 1.1.19+20180928.0d2680780-1.8
  • pacemaker >= 1.1.19+20180928.0d2680780-1.8
  • pacemaker-cli >= 1.1.19+20180928.0d2680780-1.8
  • pacemaker-cts >= 1.1.19+20180928.0d2680780-1.8
  • pacemaker-remote >= 1.1.19+20180928.0d2680780-1.8
SUSE Linux Enterprise High Availability 12 SP5
  • libpacemaker3 >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cli >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-remote >= 1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise High Availability 15
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-1.14
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-1.14
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpacemaker-devel >= 1.1.13-10.4
  • pacemaker-cts >= 1.1.13-10.4
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpacemaker-devel >= 1.1.15-19.15
  • pacemaker-cts >= 1.1.15-19.15
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpacemaker-devel >= 1.1.16-4.8
  • pacemaker-cts >= 1.1.16-4.8
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpacemaker-devel >= 1.1.19+20180928.0d2680780-1.8
  • pacemaker-cts >= 1.1.19+20180928.0d2680780-1.8
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpacemaker-devel >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise Software Development Kit 12
  • libpacemaker-devel >= 1.1.12-7.1
  • pacemaker-cts >= 1.1.12-7.1
openSUSE Tumbleweed
  • libpacemaker-devel >= 1.1.15+git20161104.b6f251a-1.1
  • libpacemaker3 >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-cli >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-cts >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-remote >= 1.1.15+git20161104.b6f251a-1.1
Patchnames:
openSUSE Tumbleweed GA libpacemaker-devel-1.1.15+git20161104.b6f251a-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 11 SP1 cluster-glue Released
SUSE Linux Enterprise High Availability Extension 15 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One cluster-glue Released