Upstream information

CVE-2010-0628 at MITRE

Description

The spnego_gss_accept_sec_context function in lib/gssapi/spnego/spnego_mech.c in the SPNEGO GSS-API functionality in MIT Kerberos 5 (aka krb5) 1.7 before 1.7.2 and 1.8 before 1.8.1 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via an invalid packet that triggers incorrect preparation of an error token.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 582557 [RESOLVED / FIXED], 586981 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Desktop 12 GA krb5
SUSE Linux Enterprise Desktop 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA krb5
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA krb5
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA krb5
SUSE Linux Enterprise Module for Basesystem 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA krb5
SUSE Linux Enterprise Module for Server Applications 15
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA krb5-plugin-kdb-ldap
SUSE Linux Enterprise Server 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
  • krb5-doc >= 1.12.1-6.3
  • krb5-plugin-kdb-ldap >= 1.12.1-6.3
  • krb5-plugin-preauth-otp >= 1.12.1-6.3
  • krb5-plugin-preauth-pkinit >= 1.12.1-6.3
  • krb5-server >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Server 12 GA krb5
SUSE Linux Enterprise Server 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
  • krb5-doc >= 1.12.1-19.1
  • krb5-plugin-kdb-ldap >= 1.12.1-19.1
  • krb5-plugin-preauth-otp >= 1.12.1-19.1
  • krb5-plugin-preauth-pkinit >= 1.12.1-19.1
  • krb5-server >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA krb5
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA krb5
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA krb5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA krb5
SUSE Linux Enterprise Software Development Kit 12
  • krb5-devel >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA krb5-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • krb5-devel >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA krb5-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA krb5-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA krb5-devel
openSUSE 11.2
  • krb5-apps-clients-debuginfo >= 1.7-6.4.1
  • krb5-apps-servers-debuginfo >= 1.7-6.4.1
  • krb5-client-debuginfo >= 1.7-6.4.1
  • krb5-debuginfo >= 1.7-6.4.1
  • krb5-debuginfo-32bit >= 1.7-6.4.1
  • krb5-debugsource >= 1.7-6.4.1
  • krb5-mini-debuginfo >= 1.7-6.4.1
  • krb5-mini-debugsource >= 1.7-6.4.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.7-6.4.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.7-6.4.1
  • krb5-server-debuginfo >= 1.7-6.4.1
openSUSE 11.2
  • krb5 >= 1.7-6.4.1
  • krb5-32bit >= 1.7-6.4.1
  • krb5-apps-clients >= 1.7-6.4.1
  • krb5-apps-servers >= 1.7-6.4.1
  • krb5-client >= 1.7-6.4.1
  • krb5-devel >= 1.7-6.4.1
  • krb5-devel-32bit >= 1.7-6.4.1
  • krb5-mini >= 1.7-6.4.1
  • krb5-mini-devel >= 1.7-6.4.1
  • krb5-plugin-kdb-ldap >= 1.7-6.4.1
  • krb5-plugin-preauth-pkinit >= 1.7-6.4.1
  • krb5-server >= 1.7-6.4.1
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5
openSUSE Leap 42.1
  • krb5 >= 1.12.1-19.9
  • krb5-32bit >= 1.12.1-19.9
  • krb5-client >= 1.12.1-19.9
  • krb5-devel >= 1.12.1-19.9
Patchnames:
openSUSE Leap 42.1 GA krb5
openSUSE Leap 42.2
  • krb5 >= 1.12.5-5.13
  • krb5-32bit >= 1.12.5-5.13
  • krb5-client >= 1.12.5-5.13
  • krb5-devel >= 1.12.5-5.13
Patchnames:
openSUSE Leap 42.2 GA krb5
openSUSE Leap 42.3
  • krb5 >= 1.12.5-7.17
  • krb5-32bit >= 1.12.5-7.17
  • krb5-client >= 1.12.5-7.17
  • krb5-devel >= 1.12.5-7.17
Patchnames:
openSUSE Leap 42.3 GA krb5
openSUSE Tumbleweed
  • krb5 >= 1.15-1.1
  • krb5-32bit >= 1.15-1.1
  • krb5-client >= 1.15-1.1
  • krb5-devel >= 1.15-1.1
  • krb5-devel-32bit >= 1.15-1.1
  • krb5-doc >= 1.15-1.1
  • krb5-mini >= 1.15-1.1
  • krb5-mini-devel >= 1.15-1.1
  • krb5-plugin-kdb-ldap >= 1.15-1.1
  • krb5-plugin-preauth-otp >= 1.15-1.1
  • krb5-plugin-preauth-pkinit >= 1.15-1.1
  • krb5-server >= 1.15-1.1
Patchnames:
openSUSE Tumbleweed GA krb5