Upstream information

CVE-2010-0624 at MITRE

Description

Heap-based buffer overflow in the rmt_read__ function in lib/rtapelib.c in the rmt client functionality in GNU tar before 1.23 and GNU cpio before 2.11 allows remote rmt servers to cause a denial of service (memory corruption) or possibly execute arbitrary code by sending more data than was requested, related to archive filenames that contain a : (colon) character.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 579475 [RESOLVED / FIXED], 608034 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • cpio >= 2.11-26.182
  • cpio-lang >= 2.11-26.182
  • tar >= 1.27.1-2.22
  • tar-lang >= 1.27.1-2.22
Patchnames:
SUSE Linux Enterprise Desktop 12 GA cpio
SUSE Linux Enterprise Desktop 12 SP1
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
  • tar >= 1.27.1-4.1
  • tar-lang >= 1.27.1-4.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA cpio
SUSE Linux Enterprise Desktop 12 SP1 GA tar
SUSE Linux Enterprise Desktop 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
  • tar >= 1.27.1-8.1
  • tar-lang >= 1.27.1-8.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA cpio
SUSE Linux Enterprise Desktop 12 SP2 GA tar
SUSE Linux Enterprise Desktop 12 SP3
  • cpio >= 2.11-35.1
  • cpio-lang >= 2.11-35.1
  • tar >= 1.27.1-14.1
  • tar-lang >= 1.27.1-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA cpio
SUSE Linux Enterprise Desktop 12 SP3 GA tar
SUSE Linux Enterprise Module for Basesystem 15
  • cpio >= 2.12-1.439
  • cpio-lang >= 2.12-1.439
  • cpio-mt >= 2.12-1.439
  • tar >= 1.30-1.3
  • tar-lang >= 1.30-1.3
  • tar-rmt >= 1.30-1.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA cpio
SUSE Linux Enterprise Module for Basesystem 15 GA tar
SUSE Linux Enterprise Server 11
  • cpio >= 2.9-75.27.24.1
  • cpio-lang >= 2.9-75.27.24.1
  • tar >= 1.20-23.23.1
Patchnames:
slessp0-cpio
slessp0-tar
SUSE Linux Enterprise Server 11 SP2
  • tar >= 1.26-1.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA tar
SUSE Linux Enterprise Server 11 SP3
  • tar >= 1.26-1.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA tar
SUSE Linux Enterprise Server 11 SP4
  • tar >= 1.26-1.2.6.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA tar
SUSE Linux Enterprise Server 12
  • cpio >= 2.11-26.182
  • cpio-lang >= 2.11-26.182
  • tar >= 1.27.1-2.22
  • tar-lang >= 1.27.1-2.22
Patchnames:
SUSE Linux Enterprise Server 12 GA cpio
SUSE Linux Enterprise Server 12 SP1
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
  • tar >= 1.27.1-4.1
  • tar-lang >= 1.27.1-4.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA cpio
SUSE Linux Enterprise Server 12 SP1 GA tar
SUSE Linux Enterprise Server 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
  • tar >= 1.27.1-8.1
  • tar-lang >= 1.27.1-8.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA cpio
SUSE Linux Enterprise Server 12 SP2 GA tar
SUSE Linux Enterprise Server 12 SP3
  • cpio >= 2.11-35.1
  • cpio-lang >= 2.11-35.1
  • tar >= 1.27.1-14.1
  • tar-lang >= 1.27.1-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA cpio
SUSE Linux Enterprise Server 12 SP3 GA tar
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
  • tar >= 1.27.1-8.1
  • tar-lang >= 1.27.1-8.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA cpio
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA tar
SUSE Linux Enterprise Server for SAP Applications 11
  • cpio >= 2.9-75.27.24.1
  • cpio-lang >= 2.9-75.27.24.1
  • tar >= 1.20-23.23.1
Patchnames:
slessp0-cpio
slessp0-tar
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • cpio >= 2.6-19.26.1
sles10-sp3-debuginfo.ia64
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.s390x
sled10-sp3.x86
sled10-sp3.x86-64
sles10-sp3.x86
sles10-sp3-debuginfo.x86-64
sles10-sp3-debuginfo.s390x
sles10-sp3.ia64
ZYPP Patch Nr: 6948
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • tar >= 1.15.1-23.16.1
sles10-sp3.ppc
sles10-sp3.x86-64
sled10-sp3.x86
sles10-sp3.ia64
sled10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3.x86
ZYPP Patch Nr: 6922
openSUSE 11.0
  • tar-debuginfo >= 1.19-35.2
  • tar-debugsource >= 1.19-35.2
openSUSE 11.0
  • tar >= 1.19-35.2
openSUSE 11.1
  • tar-debuginfo >= 1.20-23.12.1
  • tar-debugsource >= 1.20-23.12.1
openSUSE 11.1
  • tar >= 1.20-23.12.1
openSUSE 11.2
  • tar-debuginfo >= 1.21-4.3.1
  • tar-debugsource >= 1.21-4.3.1
openSUSE 11.2
  • tar >= 1.21-4.3.1
  • tar-lang >= 1.21-4.3.1
Open Enterprise Server
  • cpio >= 2.6-70.5
core9.ppc
core9.s390x
core9.x86
core9.ia64
sles9-oes.x86
core9.s390
sles9-nlpos.x86
core9.x86-64
YOU Patch Nr: 12603
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • tar >= 1.20-23.23.1
sles11.x86
sles11.x86-64
sled11.x86
sled11.x86-64
sles11.s390x
sles11.ppc
sles11.ia64
SAT Patch Nr: 2124
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • cpio >= 2.9-75.27.24.1
  • cpio-lang >= 2.9-75.27.24.1
sles11.x86
sles11.ia64
sled11.x86-64
sles11.x86-64
sles11.s390x
sles11.ppc
sled11.x86
SAT Patch Nr: 2198
Open Enterprise Server
  • tar >= 1.13.25-325.12
core9.s390x
sles9-nlpos.x86
core9.x86-64
core9.ppc
sles9-oes.x86
core9.ia64
core9.x86
core9.s390
YOU Patch Nr: 12596
openSUSE Leap 15.0
  • cpio >= 2.12-lp150.1.48
  • cpio-lang >= 2.12-lp150.1.48
  • cpio-mt >= 2.12-lp150.1.48
  • tar >= 1.29-lp150.1.12
  • tar-lang >= 1.29-lp150.1.12
  • tar-rmt >= 1.29-lp150.1.12
Patchnames:
openSUSE Leap 15.0 GA cpio
openSUSE Leap 15.0 GA tar
openSUSE Leap 42.1
  • cpio >= 2.11-30.4
  • cpio-lang >= 2.11-30.4
  • tar >= 1.27.1-4.1
  • tar-lang >= 1.27.1-4.1
Patchnames:
openSUSE Leap 42.1 GA cpio
openSUSE Leap 42.1 GA tar
openSUSE Leap 42.2
  • cpio >= 2.11-31.51
  • cpio-lang >= 2.11-31.51
  • tar >= 1.27.1-6.4
  • tar-lang >= 1.27.1-6.4
Patchnames:
openSUSE Leap 42.2 GA cpio
openSUSE Leap 42.2 GA tar
openSUSE Leap 42.3
  • cpio >= 2.11-37.12
  • cpio-lang >= 2.11-37.12
  • tar >= 1.27.1-14.3
  • tar-lang >= 1.27.1-14.3
Patchnames:
openSUSE Leap 42.3 GA cpio
openSUSE Leap 42.3 GA tar
openSUSE Tumbleweed
  • cpio >= 2.12-3.90
  • cpio-lang >= 2.12-3.90
  • tar >= 1.29-2.1
  • tar-backup-scripts >= 1.29-2.1
  • tar-lang >= 1.29-2.1
  • tar-tests >= 1.29-2.1
Patchnames:
openSUSE Tumbleweed GA cpio
openSUSE Tumbleweed GA tar


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 tar Released
SUSE Linux Enterprise Desktop 10 SP4 tar Released
SUSE Linux Enterprise Desktop 11 GA tar Released
SUSE Linux Enterprise Desktop 11 SP1 tar Released
SUSE Linux Enterprise Desktop 11 SP2 tar Released
SUSE Linux Enterprise Desktop 11 SP3 tar Released
SUSE Linux Enterprise Desktop 11 SP4 tar Released
SUSE Linux Enterprise Server 10 SP3 tar Released
SUSE Linux Enterprise Server 10 SP4 tar Released
SUSE Linux Enterprise Server 10 SP4 LTSS tar Released
SUSE Linux Enterprise Server 11 SP1 tar Released
SUSE Linux Enterprise Server 11 SP1 LTSS tar Released
SUSE Linux Enterprise Server 11 SP2 tar Released
SUSE Linux Enterprise Server 11 SP2 LTSS tar Released
SUSE Linux Enterprise Server 11 SP3 tar Released
SUSE Linux Enterprise Server 11 SP3 LTSS tar Released
SUSE Linux Enterprise Server 11 SP4 tar Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 tar Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 tar Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 tar Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 tar Released
SUSE Linux Enterprise Server for VMWare 11 SP2 tar Released
SUSE Linux Enterprise Server for VMWare 11 SP3 tar Released