Upstream information

CVE-2010-0409 at MITRE

Description

Buffer overflow in the GMIME_UUENCODE_LEN macro in gmime/gmime-encodings.h in GMime before 2.4.15 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via input data for a uuencode operation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 576923 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gmime-2_4-devel >= 2.4.8-1.2.55
  • gmime-devel >= 2.2.23-1.50.1
  • gmime-sharp >= 2.2.23-1.50.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA gmime-2_4-devel-2.4.8-1.2.55
SUSE Linux Enterprise Server 11 SP1
  • gmime >= 2.2.23-1.41.1
  • gmime-2_4 >= 2.4.8-1.2.55
  • gmime-doc >= 2.2.23-1.41.1
  • libgmime-2_0-3 >= 2.2.23-1.41.1
  • libgmime-2_4-2 >= 2.4.8-1.2.55
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA gmime-2.2.23-1.41.1
SUSE Linux Enterprise Server 11 SP2
  • gmime >= 2.2.23-1.50.1
  • gmime-2_4 >= 2.4.8-1.2.55
  • gmime-doc >= 2.2.23-1.50.1
  • libgmime-2_0-3 >= 2.2.23-1.50.1
  • libgmime-2_4-2 >= 2.4.8-1.2.55
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA gmime-2.2.23-1.50.1
SUSE Linux Enterprise Server 11 SP3
  • gmime >= 2.2.23-1.50.1
  • gmime-2_4 >= 2.4.8-1.2.55
  • gmime-doc >= 2.2.23-1.50.1
  • libgmime-2_0-3 >= 2.2.23-1.50.1
  • libgmime-2_4-2 >= 2.4.8-1.2.55
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA gmime-2.2.23-1.50.1
SUSE Linux Enterprise Server 11 SP4
  • gmime >= 2.2.23-1.50.1
  • gmime-2_4 >= 2.4.8-1.2.55
  • gmime-2_4-devel >= 2.4.8-1.2.55
  • gmime-devel >= 2.2.23-1.50.1
  • gmime-doc >= 2.2.23-1.50.1
  • gmime-sharp >= 2.2.23-1.50.1
  • libgmime-2_0-3 >= 2.2.23-1.50.1
  • libgmime-2_4-2 >= 2.4.8-1.2.55
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gmime-2.2.23-1.50.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA gmime-2_4-devel-2.4.8-1.2.55
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • gmime >= 2.2.23-1.41.1
  • gmime-doc >= 2.2.23-1.41.1
  • libgmime-2_0-3 >= 2.2.23-1.41.1
Patchnames:
slessp0-gmime


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 gmime Released
SUSE Linux Enterprise Desktop 11 SP1 gmime Released
SUSE Linux Enterprise Desktop 11 SP2 gmime Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search gmime Released
SUSE Linux Enterprise Server 11 gmime Released
SUSE Linux Enterprise Server 11 SP1 gmime Released
SUSE Linux Enterprise Server 11 SP1 LTSS gmime Released
SUSE Linux Enterprise Server for SAP Applications 11 gmime Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 gmime Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 gmime Released
SUSE Linux Enterprise Software Development Kit 11 gmime Released
SUSE Linux Enterprise Software Development Kit 11 SP1 gmime Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 03:34:49 2013
CVE page last modified: Sat Jun 15 21:14:26 2024