Upstream information

CVE-2010-0015 at MITRE

Description

nis/nss_nis/nis-pwd.c in the GNU C Library (aka glibc or libc6) 2.7 and Embedded GLIBC (EGLIBC) 2.10.2 adds information from the passwd.adjunct.byname map to entries in the passwd map, which allows remote attackers to obtain the encrypted passwords of NIS accounts by calling the getpwnam function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 569091 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • glibc >= 2.11.1-0.30.1
  • glibc-32bit >= 2.11.1-0.58.1
  • glibc-devel >= 2.11.1-0.30.1
  • glibc-devel-32bit >= 2.11.1-0.58.1
  • glibc-html >= 2.11.1-0.30.1
  • glibc-i18ndata >= 2.11.1-0.30.1
  • glibc-info >= 2.11.1-0.30.1
  • glibc-locale >= 2.11.1-0.30.1
  • glibc-locale-32bit >= 2.11.1-0.58.1
  • glibc-locale-x86 >= 2.11.1-0.38.1
  • glibc-profile >= 2.11.1-0.30.1
  • glibc-profile-32bit >= 2.11.1-0.58.1
  • glibc-profile-x86 >= 2.11.1-0.38.1
  • glibc-x86 >= 2.11.1-0.38.1
  • libxcrypt >= 3.0.3-0.4.1
  • libxcrypt-32bit >= 3.0.3-0.4.1
  • nscd >= 2.11.1-0.30.1
  • pam-modules >= 11-1.18.1
  • pam-modules-32bit >= 11-1.18.1
  • pwdutils >= 3.2.8-0.4.1
  • pwdutils-plugin-audit >= 3.2.8-0.4.1
Patchnames:
slessp1-glibc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 glibc Unsupported
SLED-10-SP4 glibc Released
SLES-10-SP3 glibc Unsupported
SLES-10-SP4 glibc Released
SLES_LTSS-10-SP4 glibc Released
SUSE Linux Enterprise Desktop 11 glibc Affected
SUSE Linux Enterprise Desktop 11 SP1 glibc Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search glibc Affected
SUSE Linux Enterprise Server 11 glibc Affected
SUSE Linux Enterprise Server 11 SP1 glibc Affected
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Affected
SUSE Linux Enterprise Server for SAP Business All-in-One glibc Affected
SUSE Linux Enterprise Software Development Kit 11 glibc Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 glibc Affected