Upstream information

CVE-2010-0001 at MITRE

Description

Integer underflow in the unlzw function in unlzw.c in gzip before 1.4 on 64-bit platforms, as used in ncompress and probably others, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted archive that uses LZW compression, leading to an array index error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 570331 [RESOLVED / FIXED], 588113 [NEEDINFO]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Desktop 12 GA gzip
SUSE Linux Enterprise Desktop 12 SP1
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA gzip
SUSE Linux Enterprise Desktop 12 SP2
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA gzip
SUSE Linux Enterprise Desktop 12 SP3
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gzip
SUSE Linux Enterprise Module for Basesystem 15
  • gzip >= 1.9-2.21
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gzip
SUSE Linux Enterprise Server 11
  • gzip >= 1.3.12-69.19.1
Patchnames:
slessp0-gzip
SUSE Linux Enterprise Server 11 SP1
  • gzip >= 1.3.12-69.19.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA gzip
SUSE Linux Enterprise Server 11 SP2
  • gzip >= 1.3.12-69.19.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA gzip
SUSE Linux Enterprise Server 11 SP3
  • gzip >= 1.3.12-69.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA gzip
SUSE Linux Enterprise Server 11 SP4
  • gzip >= 1.3.12-69.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gzip
SUSE Linux Enterprise Server 12
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Server 12 GA gzip
SUSE Linux Enterprise Server 12 SP1
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA gzip
SUSE Linux Enterprise Server 12 SP2
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA gzip
SUSE Linux Enterprise Server 12 SP3
  • gzip >= 1.6-7.392
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gzip
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gzip >= 1.6-7.209
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA gzip
SUSE Linux Enterprise Server for SAP Applications 11
  • gzip >= 1.3.12-69.19.1
Patchnames:
slessp0-gzip
SUSE Linux Enterprise Server for SAP 10 SP2
  • gzip >= 1.3.5-159.10.1
sled10-sp2.x86-64
sles10-sp2.x86
sled10-sp2.x86
sles10-sp2.s390x
sles10-sp2.ia64
sles10-sp2.x86-64
sles10-sp2.ppc
ZYPP Patch Nr: 6792
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • gzip >= 1.3.5-159.10.1
sles10-sp3.x86-64
sles10-sp3.ia64
sles10-sp3.x86
sles10-sp3.ppc
sles10-sp3.s390x
sled10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 6793
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • gzip >= 1.3.5-136.16
sles9-nld.x86
core9.x86
sles9-nlpos.x86
sles9-nld.x86-64
core9.ia64
core9.s390
sles9-oes.x86
core9.ppc
core9.x86-64
core9.s390x
YOU Patch Nr: 12573
SUSE Linux Enterprise 11 Moblin 2.0
  • gzip-debuginfo >= 1.3.12-69.19.1
  • gzip-debugsource >= 1.3.12-69.19.1
SAT Patch Nr: 1835
SUSE Linux Enterprise 11 Moblin 2.0
  • gzip >= 1.3.12-69.19.1
SAT Patch Nr: 1835
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • gzip >= 1.3.12-69.19.1
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sles11.s390x
sles11.ia64
sles11.x86
sles11.x86-64
sle11-debuginfo.ppc
sled11.x86-64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.ia64
SAT Patch Nr: 1839
openSUSE 11.0
  • gzip-debuginfo >= 1.3.12-72.2
  • gzip-debugsource >= 1.3.12-72.2
openSUSE 11.0
  • gzip >= 1.3.12-72.2
openSUSE 11.1
  • gzip-debuginfo >= 1.3.12-68.39.1
  • gzip-debugsource >= 1.3.12-68.39.1
openSUSE 11.1
  • gzip >= 1.3.12-68.39.1
openSUSE 11.2
  • gzip-debuginfo >= 1.3.12-100.5.1
  • gzip-debugsource >= 1.3.12-100.5.1
openSUSE 11.2
  • gzip >= 1.3.12-100.5.1
openSUSE Leap 15.0
  • gzip >= 1.9-lp150.2.16
Patchnames:
openSUSE Leap 15.0 GA gzip
openSUSE Leap 42.1
  • gzip >= 1.6-9.4
Patchnames:
openSUSE Leap 42.1 GA gzip
openSUSE Leap 42.2
  • gzip >= 1.6-10.53
Patchnames:
openSUSE Leap 42.2 GA gzip
openSUSE Leap 42.3
  • gzip >= 1.6-12.15
Patchnames:
openSUSE Leap 42.3 GA gzip
openSUSE Tumbleweed
  • gzip >= 1.8-1.29
Patchnames:
openSUSE Tumbleweed GA gzip


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 gzip Released
SUSE Linux Enterprise Desktop 10 SP4 gzip Released
SUSE Linux Enterprise Desktop 11 GA gzip Released
SUSE Linux Enterprise Desktop 11 SP1 gzip Released
SUSE Linux Enterprise Desktop 11 SP2 gzip Released
SUSE Linux Enterprise Desktop 11 SP3 gzip Released
SUSE Linux Enterprise Desktop 11 SP4 gzip Released
SUSE Linux Enterprise Server 10 SP3 gzip Released
SUSE Linux Enterprise Server 10 SP4 gzip Released
SUSE Linux Enterprise Server 10 SP4 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP1 gzip Released
SUSE Linux Enterprise Server 11 SP1 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP2 gzip Released
SUSE Linux Enterprise Server 11 SP2 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP3 gzip Released
SUSE Linux Enterprise Server 11 SP3 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP4 gzip Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 gzip Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 gzip Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 gzip Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 gzip Released
SUSE Linux Enterprise Server for VMWare 11 SP2 gzip Released
SUSE Linux Enterprise Server for VMWare 11 SP3 gzip Released