Upstream information

CVE-2010-0001 at MITRE

Description

Integer underflow in the unlzw function in unlzw.c in gzip before 1.4 on 64-bit platforms, as used in ncompress and probably others, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted archive that uses LZW compression, leading to an array index error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 570331 [RESOLVED / FIXED], 588113 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • gzip >= 1.6-9.3.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • gzip >= 1.6-7.392
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • gzip >= 1.10-2.12
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gzip >= 1.9-2.21
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • gzip >= 1.3.12-69.19.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • gzip >= 1.3.12-69.23.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • gzip >= 1.3.12-69.19.1
Patchnames:
slessp0-gzip
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gzip >= 1.6-7.209
openSUSE Leap 15.0
  • gzip >= 1.9-lp150.2.16
Patchnames:
openSUSE Leap 15.0 GA gzip-1.9-lp150.2.16
openSUSE Tumbleweed
  • gzip >= 1.8-1.29
Patchnames:
openSUSE Tumbleweed GA gzip-1.8-1.29


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 gzip Released
SLED-10-SP4 gzip Released
SLES for SAP Applications gzip Released
SLES-10-SP3 gzip Released
SLES-10-SP4 gzip Released
SLES_LTSS-10-SP4 gzip Released
SUSE Linux Enterprise Desktop 11 gzip Released
SUSE Linux Enterprise Desktop 11 SP1 gzip Released
SUSE Linux Enterprise Desktop 11 SP2 gzip Released
SUSE Linux Enterprise Desktop 11 SP3 gzip Released
SUSE Linux Enterprise Desktop 11 SP4 gzip Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search gzip Released
SUSE Linux Enterprise Server 11 SP1 gzip Released
SUSE Linux Enterprise Server 11 SP1 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP2 gzip Released
SUSE Linux Enterprise Server 11 SP2 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP2 for VMware gzip Released
SUSE Linux Enterprise Server 11 SP3 gzip Released
SUSE Linux Enterprise Server 11 SP3 LTSS gzip Released
SUSE Linux Enterprise Server 11 SP3 for VMware gzip Released
SUSE Linux Enterprise Server 11 SP4 gzip Released
SUSE Linux Enterprise Server 11 SP4 LTSS gzip Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 gzip Released