Upstream information

CVE-2009-4273 at MITRE

Description

stap-server in SystemTap before 1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in stap command-line arguments in a request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 574243 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • systemtap >= 3.0-20.11
  • systemtap-runtime >= 3.0-20.11
  • systemtap-server >= 3.0-20.11
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • systemtap >= 3.2-7.6.1
  • systemtap-runtime >= 3.2-7.6.1
  • systemtap-sdt-devel >= 3.2-7.6.1
  • systemtap-server >= 3.2-7.6.1
SUSE Linux Enterprise Module for Development Tools 15
  • systemtap >= 3.2-5.64
  • systemtap-runtime >= 3.2-5.64
  • systemtap-sdt-devel >= 3.2-5.64
  • systemtap-server >= 3.2-5.64
SUSE Linux Enterprise Server 11 SP1
  • systemtap >= 1.0-0.15.16
  • systemtap-client >= 1.0-0.15.16
  • systemtap-server >= 1.0-0.15.16
SUSE Linux Enterprise Server 11 SP2
  • systemtap >= 1.5-0.7.54
  • systemtap-server >= 1.5-0.7.54
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • systemtap >= 1.5-0.9.1
  • systemtap-server >= 1.5-0.9.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • systemtap >= 0.7.1-42.5.1
Patchnames:
slessp0-systemtap
SUSE Linux Enterprise Server 12 SP1
  • systemtap >= 2.5-4.44
  • systemtap-runtime >= 2.5-4.44
  • systemtap-server >= 2.5-4.44
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • systemtap >= 3.0-7.15
  • systemtap-runtime >= 3.0-7.15
  • systemtap-server >= 3.0-7.15
SUSE Linux Enterprise Server 12 SP3
  • systemtap >= 3.0-10.15
  • systemtap-runtime >= 3.0-10.15
  • systemtap-server >= 3.0-10.15
SUSE Linux Enterprise Server 12 SP4
  • systemtap >= 3.0-15.13
  • systemtap-runtime >= 3.0-15.13
  • systemtap-server >= 3.0-15.13
SUSE Linux Enterprise Server 12
  • systemtap >= 2.5-1.55
  • systemtap-runtime >= 2.5-1.55
  • systemtap-server >= 2.5-1.55
SUSE Linux Enterprise Software Development Kit 12 SP1
  • systemtap-sdt-devel >= 2.5-4.44
SUSE Linux Enterprise Software Development Kit 12 SP2
  • systemtap-sdt-devel >= 3.0-7.15
SUSE Linux Enterprise Software Development Kit 12 SP3
  • systemtap-sdt-devel >= 3.0-10.15
SUSE Linux Enterprise Software Development Kit 12 SP4
  • systemtap-sdt-devel >= 3.0-15.13
SUSE Linux Enterprise Software Development Kit 12 SP5
  • systemtap-sdt-devel >= 3.0-20.11
SUSE Linux Enterprise Software Development Kit 12
  • systemtap-sdt-devel >= 2.5-1.55
openSUSE Tumbleweed
  • systemtap >= 3.0-1.6
  • systemtap-runtime >= 3.0-1.6
  • systemtap-sdt-devel >= 3.0-1.6
  • systemtap-server >= 3.0-1.6
Patchnames:
openSUSE Tumbleweed GA systemtap


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES-10-SP3 systemtap Unsupported
SUSE Linux Enterprise Server 11 systemtap Released